[4.9][OS X] Missing UE4Editor-InputDevice.dylib

I’m trying to build a project that contains a game plugin that relies on the IMotionController and IInputDevice modules. The project builds and runs correctly in Windows, but in OS X with XCode I get the following error:

clang: error: no such file or directory: '/Users/Shared/UnrealEngine/4.9/Engine/Binaries/Mac/UE4Editor.app/Contents/MacOS/UE4Editor-InputDevice.dylib'

I was able to build the project + plugin using the latest source from promoted branched (marked as 4.10.0 on the Editor splash screen). I hope this bug gets fixed in a hotfix before then, but at least we know the library does build in OSX. I’ll leave this unanswered until someone from Epic sees it, but please feel free to close the issue as soon as you’ve made a note to include this library in the Mac binary release.

Hey bullale-

The fixes that are included in a hotfix are normally reserved for major crashes. I will see if I can find where the specific fix for this issue is in the promoted branch and ask that it be included in the next hotfix but I can’t say for certain that this will be the case. If you’re still having this issues after 4.10 release, feel free to comment here again.

I just finished building the 4.9 source (release branch) and that also works. So it seems like everything is in place in 4.9 only that the 4.9 binary distribution is missing this library. It should be trivial to add it back.

I’m running into the same issue. It seems the shell commandline to build doesn’t do so with the correct dylib. Notice in the below example, the output is UE4Editor-MyProject-6889.dylib but the shell script tryies to build 8064.

Everytime I compile, I get a new number, however the 8064 persists.

Info Setting up Mono
Info /Users/Shared/UnrealEngine/4.9/Engine /Users/Shared/UnrealEngine/4.9/Engine/Binaries/Mac
Info Compiling game modules for hot reload
Info Performing 2 actions (4 in parallel)
Info [1/2] Link UE4Editor-MyProject-6889.dylib
Info [2/2] sh -c 'rm -rf "/Users/Twigg/Documents/Unreal Projects/MyProject/Binaries/Mac/UE4Editor-MyProject-8064.dSYM"; "/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/"dsymutil -f "/Users/Twigg/Documents/Unreal Projects/MyProject/Binaries/Mac/UE4Editor-MyProject-8064.dylib" -o "/Users/Twigg/Documents/Unreal Projects/MyProject/Binaries/Mac/UE4Editor-MyProject-8064.dSYM"'
Info error: unable to open executable '/Users/Twigg/Documents/Unreal Projects/MyProject/Binaries/Mac/UE4Editor-MyProject-8064.dylib': No such file or directory

The dylib has added with 4.9.2 hot fix! Thank you!!

However, added dylib is not usable because it is linked to different dylib.

% otool -L /Users/Shared/UnrealEngine/4.9/Engine/Binaries/Mac/UE4Editor.app/Contents/MacOS/UE4Editor-InputDevice.dylib
    @rpath/UE4Editor-InputDevice.dylib (compatibility version 4.9.0, current version 0.0.0)
    @rpath/UE4Editor-Core-Mac-Debug.dylib (compatibility version 4.9.0, current version 0.0.0)
    @rpath/UE4Editor-CoreUObject-Mac-Debug.dylib (compatibility version 4.9.0, current version 0.0.0)
    @rpath/UE4Editor-Engine-Mac-Debug.dylib (compatibility version 4.9.0, current version 0.0.0)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1225.1.1)

So I needed to fix links by install_name_tools.
I appreciate if you can fix that for future convenience!

Many thanks.

The dylib has added with 4.9.2 hot fix!

I’m using 4.9.2 and I’m still getting the original error, and I can’t find the dylib. is there some way to just download it?

EDIT: Ok, I’m really at a loss here. I tried building the editor from source (the 4.9.2 source for the record), but that didn’t make the .dylib file. I tried just putting an empty dylib file (creating a dylib from an empty source file) and putting it where the compiler expects, and the plugin builds, but the editor crashes when loading a project with the plugin. I’m currently trying to get the editor to directly build the module as a plugin, but not with a lot of success.

I’m using the 4.10.0 Preview 1 and I’m still getting this error message when I add InputDevice as a public dependency.

I solved my particular problem by deleting my Intermediate’s folder and rebuilding.

On UE 4.10 release here. Still have this issue on OSX.11.1.
UE4Editor-InputDevice.dylib absent.

Hey altares-

Are you trying to use IMotionController and IInputDevice modules as bullale first reported? Can you provide any additional information about how you got this error?


No, actually I’m trying to integrate psmove-ue4 into my project using the tutorial in:


My project is a simple c++ UE4 empty template to which I added that plugin.

That’s my plugin. So yes, he is using IMotionController and IInputDevice.

Hey bullale-

You originally mentioned that you no longer had this problem when the promoted branch was 4.10, can you confirm that you no longer have the same issue in 4.10.1?


Are you using the binary version of the engine from the launcher or a source built version from ?

Using the binary distribution of 4.10. Do you think I might need to use the source instead? Nice plugin btw, will be very useful when I get it to work.

I updated the binary to 4.10.1 and tested the Git source version too. Still no luck:

UE4Editor-InputDevice.dylib is no where to be found

When did you last update the plugin? It may be possible that the version you’re trying to use has not been updated to work with 4.10. Can you try updating the plugin as well and trying again.

I’ll try with 4.10.1 later tonight, first with the binaries then, if that doesn’t work, from source.

Are you saying that the file UE4Editor-InputDevice.dylib no longer exists and there is a new way of building input plugins in UE4?

In that case, I shall wait for Bullale’s next release since this one is pretty old.

Did you try the plugin in 4.10.1? On my end, it doesn’t work. Have any idea?