4.9 Conversion, external reference bug

Hello Everyone,

I just wanted to see if you are all experiencing this bug. When converting my UE 4.8.2 project to UE 4.9, all of my assets and maps load and function as expected but I continue to get warnings that all my assets are externally referenced. Despite all this, building and running the stand alone game works just fine so I’m wondering if that is a bug I need to report.

Is there a work around at the moment or shoould I jut go back to 4.8.2 and wait for an update prior to converting?

Hi Mandinga,

This is a known issue and is currently under assessment. If you are getting the warnings they should not adversely affect you.

You can check this link for a work around the warnings
tl;dr: Rename the folder of your project -> open it -> save it -> rename it to the original -> open it and perform map check

I think I am having the same or very similar issue, I converted a project from 4.8.1 to 4.9 which worked fine but whenever I try to add a bsp brush to my map and save I get the external reference warning, then I imported a static mesh to the project and saved it and got no warning but as soon as I placed the mesh in the map and tried to save I got the warning again, I also imported the same static mesh into a fresh 4.9 project and placed it in the map and when I tried saving it I didn’t get the warning.

Thanks for confirming Adam.

RamP93, thanks I’ll look into this.

Cheers Guys

I get same problem in 4.9.1 :slight_smile:

Same problem, but only for navigation data at the moment

I have the same problem.

Last night we updated from 4.8.3 to 4.9.2 and we also ran into this problem…but it wasn’t only the warnings for external references, it was actually not rendering a significant amount of foilage types (3 or 4 sorts of grass).

Here the screen in 4.8.3

…and here in 4.9.2

After the third conversion it worked that all foilagetypes are rendered, but we switched back to 4.8.3 after opening the WorldScene took around 5 Minutes (not the first time…every time we tried) to open in 4.9.2 (below 1 Minute in 4.8.3).

If we skip 4.9, can we update to 4.10 or higher without any problems?

and does anyone know if Ramas current Victory Plugin is still working with 4.8?

I have ran into the same issue moving from 4.9 to 4.10

Same here, after converting my project from 4.9 to final 4.10.

For the foliage not rendering issue, I too experienced this.
I found that the material type of my foliage had been changed to “UI” instead of “Surface”. Just switch it back, and your foliage will be okay again.
Definitely a bug in the conversion process, but luckily easily fixed.

same here, from 4.9 to 4.10, external reference errors and also, my player has disappear, i checked the map properties and it has my game mode set with my player character blueprint, also i checked my player blueprint all is fine.

don’t know what is happening

In my case, removing ‘_4.10’ from name of project folder helped. Make sure your project folder has the same name as your .uproject file. Maybe it will help you to get rid of these external map reference warnings.

any ideas why my player character was disappear ? my ue 4.9 has the substance plugin installed and now when i try to oopen the converted project the engine told me if i want to download the substance plugin from the marketplace (that plugin is not available for 4.10) can the missing substance plugin affect my game causing my player character disappear ?

my two 4.9 projects converted from 4.9 to 4.10 has the same issue.

need help, please.

Issue also persists when converting from 4.10 to 4.11…

4.10 > 4.11.1 = issues

Hey guys, I deleted my saved folder and reopened the project. That fixed the issue for me. The saved folder is located in project folder. So “Gamename/Saved”. Just delete it and it will make a new one when you reload!