4.9 Anim Montage Slot are always placed in DefaultGroup

After intensive testing I conclude there is a bug in 4.9 ( 4.9.0 and also 4.9.1) concerning the Anim Montage Slot Groups.

When I create a AnimMontage Group and a AnimMontage Slot within this group, the slot I newly created en selected in the DefaultGroup after save and restart of the UE editor.


I noticed this after trying to upgrade fron 4.8.3 to 4.9. After creating a new 4.9.1 project and importing a skeletal mesh, creating an Animation Blueprint the problems also occur. In fact Custom AnimMontage SlotGroups are no longer functional in 4.9.

I already posted a thread in the forum about this issue:

Hi ipas,

I was unable to reproduce the issue here following your repro steps with a new project in 4.9.1 with a few exceptions as *noted below:

  1. Created a new/empty 4.9.1 project: Third Person Blueprint
  2. *Used existing skeletal mesh
  3. *Used existing AnimBlueprint AND newly created one (two different tests)
  4. Created a Slot in the AnimGraph and connected the StateMachine to Slot to Final Animation Pose
  5. Selected Slot and opened the Slot Manager
  6. Created new Slot Group= “TestGroup”
  7. Created new Slot under Slot Group = “TestSlot”
  8. Selected “TestGroup.TestSlot”
  10. Saved and closed
  11. Reopened AnimBlueprint/AnimGraph

RESULT: “TestGroup.TestSlot” remained selected

Please try this with the “compile” (Step 8 above) and see if this resolves the issue. If not, let me know how I can better reproduce your issue if possible.


To point out my case I made a short video :

No… unfortunately it still does not work. Again I created a new project, created the Group and slot, compiled, saved and restarted.
And still the slot is placed in DefaultGroup.
In this state when I reselect my custom group press the compile button it flips instantly to the default group again.

Have you examined my testproject I send you ?

This is really weird… I will test this today on a different computer… otherwise I will make a screen capture video.

I installed a fresh copy of UE 4.9.1 on a different computer and got the same result. :frowning:
(Tested it on windows 8.1 and windows 10)

Hi ipas,

Thanks for sending the video clarifying the issue. While the node itself seems to keep the change (it remains named TestSlot and is listed under TestGroup) it does appear to fall under the Default group in the Details panel once compiled and the Project has been saved, closed and reopened.

I have modified my repro steps to reflect this in the bug report: JIRA [UE-21145]. When this issue has been addressed, we will notify you with an update to this post.

Thanks, again, for your contribution towards improving UE4.

I get the same bug in 4.9.2. Why is this marked as resolved?

Yeah me too, I all my slots are are tripled copied into Defautl Group. I concluded that when I select the slot.Defaultgroup and compile the change will be set, but the dropdown got messed up. Multiple aninmontage are possible in 4.9

When a bug has been identified and a report filed and recorded, this is the most support we can offer on the AnswerHub so it is marked resolved (for now) for tracking purposes. At this point, developers are working on all reported bugs in a prioritized manner. Once a bug has been resolved, as stated above, we notify users by updating the corresponding AnswerHub post.

Hello . Just FYI . This still exists in 4.10. I’m wondering :

  1. has anyone found any workaround on this?
  2. is there an alternate way to play 2 montages at the same time?

Multiple montages at the same time is possible with this problem. Even though it looks that the slot is placed in the Default Group it is connected correctly in Unreal. I got a lot of slots en Groups and it’s a total mess but it does work.

UE team please fix this problem!

@ipas how did you get it to work? It keeps reseeting to defaultgroup. you’re saying the display is wrong but it’s actually playing from defaultgroup? this seems to be true for the AnimGraph side.

But for the individual montage asset. i can’t seem to set the group in the montage. keeps pulling back to DefaultGroup. is your asset done before 4.8 ? or you can still change them?

It does keep resetting it to the default, at least so it seems. Giving my example, when I select the Testgroup.TestSlot it flippes back to the Defaultgroup, but animations are playing from the Testgroup. So it is more like an animation slot management issue. I have like 8 different AnimationGroups, so my list is huge. When I do some changed I need to go through the entire slot list by clicking it into the correct group to be sure it is placed into this group. But the overview is just all messed up.
Hopefully this explanes a bit …

It’s getting a bit annoying that this problem is not being fixed. I rebuild my entire animation montage slot structure and it’s still a total mess. The list is getting longer and longer… Pleeeeaaassseee fix this issue ???
A clean fixed final 4.11.0 would be nice :slight_smile:

Slot names duplicating have been marked resolved for a future release of the engine while the bug of new montage slots being created in the Default Group is still currently being worked on.

bump this is occuring to me as well >.< Epic please fix this and its madly duplicating slots >.<

Having same problem since 4.9. And same problem on 4.11-preview-6. Downloading 4.11-preview-7 and probably still not fixed :{

Just tried with preview-7 and same problem here. I deleted all slots and after sometime it is still happening. I have just deleted my all of montages :\ because it is impossible without delete montages.

Probably tomorrow I will have 50 slot nodes with same name :slight_smile: