[4.9.2] Non-default MobileContentScaleFactor on iPhone 5 Creates Black Screen

If I set r.MobileContentScaleFactor to anything outside [0, 0.5, 1, 1.5, 2] it will produce a black screen but UI and sound still works.
This only happens on iPhone 5 and maybe 5s (I don’t have 5s). But any odd numbers such as 1.69, 1.44, 1.85 works on iPad 2 and iPhone 6 and 6 plus.

*I know that having odd numbers sacrifices performance but I need it to be exact 960x640 for pixel perfection.

Hey ,

I have set up a project with r.MobileContentScaleFactor included in the DefaultDevicesProfiles.ini. The project took a few seconds to load up and it initially looked like it would be a black screen but it did load. Could you please provide me a sample project to work from to ensure I have set up my project the way that you are?

Looking forward to hearing back from you, thanks!

Hi, if you change the iPhone 5 r.MobileContentScaleFactor to 1.6 or 1.7 and run it, iPhone 5 (OS 8.4.1) will blackscreen.

Not sure if this is different from changing the .ini but I changed mine through Window > Developer Tools > Device Profiles

Hey ,

I’ve ran this on the devices that I have available, based on the OS that it’s suppose to be on for our testing purposes.

  • 8.4.1 - OK
  • iPhone 5 8.1 - OK
  • iPhone 5c 8.1 - OK
  • iPhone 4 7.1 - OK

How long do you let the blackscreen sit there and load?

Thanks for looking into the issue. I am starting to wonder if this issue is only related to my project. I gave another try and left the phone for 30 minutes but still got stuck at blackscreen. Game is running because sounds and UI are working as I can press on buttons. Once I changed r.MobileContentScaleFactor to 1.5 or 2.0 the visuals will load within 1-2 seconds and everything will work correctly.

More Info:

  • Mobile HDR OFF [Project Settings > Rendering]

  • Camera is orthographic, width is 960, constrain aspect ratio ON and set to 1.777778

EDIT: Tried looking for crashlog or any log on my iPhone 5 but nothing appeared.

I tested out again on the . I used the Third Person template. The project loaded without any delay or trouble. It may be something within your project that is causing the blackscreen to appear, as you previously stated.

I manage to get my hands on and it worked fine with values other than 0.0, 0.5, 1.0, 1.5, 2.0. However the blackscreen issue still persist on iPhone 5. I will try to find the cause of this and post back here if I get any results.

Reproduced the issue on a sample project. Zip file includes:

  • .ipa
  • project file
    Download Link: https://drive…com/file/d/0BxA-6ZVRJ-z1cWtuejFVSndVV1k/view?usp=sharing

What I used and changed:

  1. I used sidescroller project as base
  2. I set the default platform to mobile while creating the project
  3. I set the camera ortho width to 960 and lock aspect ratio
  4. I turned off mobile HDR under Project Settings > Rendering
  5. Changed r.MobileContentScaleFactor for iPhone 5 to 1.69 under Windows > Developer Tools > Device Profile

Test this on iPhone 5 and it should get a black screen.

I have pushed your project to both an and an iPhone 5. Both phones displayed the project correctly. I’m beginning to think that it has to do with the operating system that’s on your iPhone 5.

Tested Devices:

    • 9.0.2
  • iPhone 5 - 7.1.2
  • iPhone 5 - 8.1

Thanks for looking into this and testing it on various devices. Not sure what is going with my iPhone 5. I am going to push the app with 1.69 and see if other people experience this issue.

Let me know what you find out. If possible, please include the types of devices including their OS version as well.


Hey ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!