4.9.2 Compiling from within Visual Studio breaks Play In Standalone


repro steps:

  1. Download this project: https://drive.google.com/open?id=0B8S2_lrZ_eT3dExDVjFNajloVFE

  2. Unzip it and open in VS and UE4 Editor

  3. Add this code in function void APlayerMainGamePwn::Tick( float DeltaTime ):

    DrawDebugSphere(GetWorld(), FVector::ZeroVector, M(100.f), 8, FColor::);

  4. Compile from within VS by hitting F7.

  5. After compilation hit PIE.Notice sphere in the center of the screen

  6. Now hit Play In Standalone Window. There is no sphere. Error


Hello ,

I see the problem but it also seems to be unique to your project as I tried the same thing in a fresh project without any issues. I’ll be looking into what could be causing this but your project is very large and it could likely be anywhere.

Is there anything that you could think of that would be disabling this drawing or impeding the tick function in Standalone in your custom code?

Hi ,

You will fail to reproduce it in fresh project, I ve tried it with also no luck. This tends to happen when project is not simple and have deacent amount of content in it. In at least two different projects of mine (both quite big) this is happening. I would recommend reproducing it in shooter example project or infiltrator demo, both of those are huge projects and I bet you will reproduce it quite easily.

As to what is causing it. When You play from Play In Standalone old game dll’s are loaded instead of fresh ones. Note that when You delete Binaries folder, then recompile solution from VS so that only one game dll will exist, it will start to work as expected.

Also recompiling from within Unreal Engine fixes this issue.

Thank you for providing that information, at least that helps narrow down what the issue is, although I’m not having any luck reproducing it in ShooterGame either. I’ve yet to see it happen in anything other than your project. I’ll give Infiltrator a try shortly, as it would be helpful to ensure that it’s a wide-spread problem rather than being unique to your project.


remember that I can send You one more project where this error occurs (also in 4.9.2).

Unfortunately, the issue doesn’t occur in Infiltrator either. I’ll take a look at the other project you have. If the cause is still not obvious, I’ll bug the issue and provide one of your projects for the reproduction case.

Hi ,

grab this link for second project where this issue occurs.

Repro steps are identical. In point 3 add code to function AMyProject4PlayerController::PlayerTick()


Thank you , with this project, I was able to convert it to 4.10 to test to see if the issue still occurred there (The previous one gave multiple compiler errors upon conversion) and discovered that it doesn’t. Could you try upgrading to 4.10 to see if you still see the issue?

Ok I will try to move to 4.10 and give feedback if this still occurs.