4.9.2 Compile button doesn't cause source compilations. Gives false positive results


this is so so so discouraging that such basic features as project compilation doesn’t work properly.

In attached video You will see that I add (invalid) code to project, then hit compile button and editor gives me false “compilation successful” message.

link text


Are there any steps that will reproduce this issue? I saw video you posted however adding bad code as shown in your video and then attempting to compile in editor fails for me as expected. If you’re able to reliably reproduce this behavior please let me know what steps lead to problem.


Hi Dough,

sorry it is total random, I’ve also failed to reproduce it. Hovewer I’ve zipped and saved my project from moment this was happening. Try to unzip project on Your machine and then try to reproduce as in video.

link text

Opening supplied project and attempting to add code / compile in editor failed compile. If you do see this happen again it may help to close/reopen project before compiling and/or trigger hot reload by compiling from within Visual Studio with editor still open.

So basicly we are ignorring issue. Compilation of a project is most basic feature You can think of, it should work always. Hot reloading and compiling projects is something that I experience to be buggy. I am not using VS for compilation (and as a programmer I really would love to) because it also sometimes randomly fails. Of cource once I go to project directory, delete some files / folders / restart editor couple of times it starts to work. But errors should not be ignored because there is workaround. Ignoring such things causes working in UE to be a very frustration struggle sometimes.

I understand and totally agree that this is hard. But lets work together to work it out. What I think is bad thing to do is to propose me a workaround solution and mark problem as solved.

Tracking what is causing false positive when compiling is incredibly difficult without being able to reliably reproduce issue. Although a workaround is not ideal solution, I can’t investigate cause further without more information. If you are able to find/post reliable steps to reproduce issue we can attempt to find root cause of problem.


Marking a post as Resolved does not imply that we are done investigating issue, only that it has either been reported or that we cannot get any further with it than we have. If you can provide some reliable reproduction steps, whether in project you supplied or preferably in a fresh project, please let us know. Until that time, we cannot continue to track every post. We will update you if we have more information or have any further questions. Thank you.

Hi ,

I think posts like this shouldn’t be marked as resolved. We didn’t resolve this issue, quite contrary. Much more adequate status would be “failed to reproduce”. My impression was that because there exists workaround, post was marked as resolved and issue was considered to be solved. I want to stress that this is not way to go. As a developer I experience many situations when I need to restart editor and/or remove binaries or do other kind of magic to continue my work. Often there are problems with very basic functionalities. This is really frustrating.

As to Hot Reloading / project compilation. I experience problems with it since I’ve started work in UE back in 4.7. I’ve spend some time today testing it back and forth and I ended up with two possible bugs discovered. (Both in really basic test cases)

Thanks for testing further. I’ve assigned those posts to and team to look into.

Unfortunately, AnswerHub doesn’t have any additional statuses for us to work with. I understand it’s not clear, and that’s why I let people know what a “Resolved” status here actually means for us in terms of tracking. Until such time as we have an alternative for public bug report submission, we have to work with what we have.

Again, with this particular post, until we have something more to work with (reliable reproduction steps and/or a consistent repro project), we can get no further. This post will be marked “Resolved” until such time as that changes.