4.9.2 Collapsed UMG still consumes mouse input

Hi, so during the game I spawn a 3D widget in front of me. Obviously any object behind the UMG cannot have its onClicked event called because I am clicking the widget in front of it.
However, even after hiding the UMG, it seems like an invisible “ghost” is there and I am still unable to click on the object behind it. If I move the invisible UMG away, I am able to click the object.

I’ve tried doing these:
-3D widget actor Hide from game
-Set Hidden
-Set Collapsed (Tried doing it to the whole widget)
-Hit Test Invisible

And none of these works. My current temporary solution to this is instead of hiding the UMG, I move the actor down -1000 in the Z axis so it’s far away from the user’s perspective, and that way it’s not blocking anything.

Hello michaeleeli,

After reading over your post, I believe that this is working as intended. If I understood you correctly you are setting the visibility of the widget. This means that the actor is still present because the actual actor is not affected, just the display of the widget that is applied will be affected. I hope that this information helps.

Make it a great day

how to solve this problem? After i hide the widget, the widget can ignore input event .

Hello liXiang,

In order to solved the issue on this thread, you would need to remove the component, scale it down so that it is too small to click, move it so that it is no longer in the way, or any other such method that would be used on any other type of actor.

Make it a great day