4.8P4 -- Packaging includes ALL files, even unused assets

This problem has actually been around since always, but anyway: if you package a game, it will include all assets in the project, even if they aren’t used by anything.

The only solution I found so far is rather unintuitive. You have to tell which maps to cook in DefaultEditor.ini:



If this is working as intended, then usability should be improved. Perhaps create a dialog (or in Project Settings → Packaging) to set these AllMaps and AlwaysCookMaps fields?

And also issue a warning the first time the user attempts to package a game, telling him/her to set AllMaps and AlwaysCookMaps, otherwise all assets will be packaged.

You can set the same thing via the Package Settings. There is an arrow at the bottom of the settings which will expose advanced settings which includes the maps to package.


Thanks for the info.

But anyway, I suggest adding a warning, when you click Package, saying that “if you do not select which maps to cook, ALL assets will be packaged, which will increase packaged game size”.

Or automatically determine it from the Game Default Map.

Thanks Pete!. Just what i was looking. Down from 4GB to just 800MB in a simple house for Archviz just selecting a map for cooking

And if i check “use pak file” and “create compressed file package” the size went down to 512MB Now i’m loving UNREAL for good.