[4.8p4] Editor crashes changing landscape material

Landscape actors created by World Composition ‘import tied landscape’. Crashes when attempting to change or clear material or ‘hole material’.

When the crashes generate crash reports to Epic, should we still report them here?

Hey Eredin,

Yes, this is the exact place we ask users to report their bugs!

The process we have in place helps us get bug reports into our system quickly as long as our users follow with our bug reporting guidelines posted on our Forums.

Take a look at our ‘How to Report a Bug’ thread on our Forums to get a better understanding of the information we will need for testing and reporting your issue.

How to Report a Bug

Let me know if you have any questions with the process, or need help finding certain information.


OK, good. I didn’t want to flood you with redundant reports.

Branch : binary

Build : Version: 4.8.0-2564697+++depot+UE4-Releases+4.8

Repro Steps :

  1. Create one or more landscape levels using world composition, and Window->Levels->Import Tiled Landscape. (mine is a .r16 file created by world machine; I specify a simple material in the import window)

  2. Set the landscape tile as the Current Level

  3. attempt to clear the Material setting for the landscape tile, or change it to any other material, or to set the ‘hole’ material.

[link text][1]

So whenever you receive a Crash Report Window, always send us the report. We have an internal system in which we can search for individual crashes based on information given to us by the user when they report a bug/crash via the AnswerHub.

Would you mind re-attaching the file? You might not have selected a file (done it before).

Thank you for providing me with the format and the information requested by the way.

oddly, the log file was 0-bytes long for the above…So I crashed it again and did a copy/paste from the crash reporter to a text file. Of course this time the log file has something in it too :

link text

Let me know if I can provide anything else that might be helpful.

Hey Eredin,

I was unable to reproduce the issue with the steps you provided. Perhaps it is related to the file you are importing. Would you mind sharing the r.16 file so I can import it and follow with your steps?

Also, if you could provide me with your ‘dxdiag’ so I can take a look at your systems hardware specifications, that would be helpful.


Happy to! It’s a little over 6Mb, so here’s a link to it in . https://www…com/s/5d1nhxs606lw9t3/CrashWhenChangingMaterialOnLandscape-addendum-20150609-1405.zip?dl=0

Hey Eredin,

So I tested the asset and everything works fine on my machine. I took a look at your systems hardware and the problem could be with your processor and your graphics cards. They are not terrible, but with the tasks you are attempting to perform, importing a large heightmap and generating a landscape and material all at the same time, could be just bogging down your system to a halt.

I am running a GTX 770 with 32 GB of RAM and Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz (12 CPUs), ~2.0GHz.

You are running a mobile dedicated graphics card the 560M and have 12 GB of RAM with Intel(R) Core™ i7-2670QM CPU @ 2.20GHz (8 CPUs), ~2.2GHz.

Let me know if you don’t think this is the issue and we can try something else, but I am pretty sure it is due to your hardware.


If I was exhausting my memory on the operation I could see it causing some kind of error (which should be handled gracefully, but that’s a different topic). As it is my physical memory is only about 25% utilized and neither my CPU nor GPU are working hard.

I tried the operation on my desktop machine which is slightly better and got the same error. (log attached)

link text

Granted, neither of these machines is a powerhouse but I am able to load and manipulate about 30 maps of the size I sent to you at one time…so I think loading and changing the material for a single map should be well within their capabilities?

IMPORTANT UPDATE - I just verified that I am in fact able to perform the material change under 4.7.6.

Okay no worries, I was not aware your computer was performing as you have stated. I usually like to mention hardware even if it is a slight possibility, as it is one of the easier restrictions to rule out if it is not the cause of the issue.

With that said, I was able to reproduce the issue with different heightmap files than the one you provided. For some reason, the heightmap you gave me was not producing the issue.

Either way, I have entered a bug report for the issue UE-16900 and we ask that if you are looking for updates to the issue to look on our Forums in the, Announcements and Releases thread found below.


If you have any other questions, or need additional assistance please let us know.


Hi Eredin, Thanks for the bug report.

It seems the crash only occurs if you assign the material to a LandscapeProxy directly instead of the shared Landscape actor. Can you work around this by selecting the Landscape actor and assigning the material there?

I fixed the bug just now. If you’re using source code you can find the fix here:



Confirmed this workaround. Thank you!

I was mistaken, sort of. While I can change the material on the landscape actor it doesn’t propagate back to the proxy and doesn’t appear in the world. What am I missing?

Thanks for the update! will this be in the next hotfix release?

The plan is to have the fix implemented for 4.8.1, but I cannot guarantee this will be the case. As mentioned earlier, we ask that users look to the Forums within our ‘Announcement and Releases’ section for updates and hotfixes.