[4.8 P3] PhysicsSerializer Errors on Project Startup

I get this on projects startup:


I have no idea why, I only know it was not there in 4.7.

I had the same issue as well when I converted my project to 4.8 on an instancedStaticMeshComponent. Did you find anything?

Hey John and Morph,

Unfortunately, I’ve not been able to reproduce this on my end.

@John, I know you had mentioned previously that you didn’t post this because you couldn’t reproduce it or know why it happened, correct?

Has it affected those assets at all in your project? I know it say’s they failed to import. Did you have to recreate the assets, did they come in anyway, or were there any other issues that arose from this?

@Morph208 Have you had any luck with getting this to reproduce in multiple projects on your end? Also the same questions as above. Is there anything that’s caused issues with your project with the assets that are linked as failed to import?

Thanks for any information you both have to share.


You are right, I could not reproduce it on my end. I don’t know exactly whether the assets got affected by it, I think they don’t and they work in game as usual. It could be that their collision does not work, but I have never tried to collide anything with them.

For the moment I’m going to mark this as resolved since I don’t really have a way of reproducing this myself. Should you or @Morph208 come across any way to reproducing this or even any issues that arise because of this please let me know.

Thanks for your help and it is always appreciated! :slight_smile:

Hey Tim,

I can confirm the issue is still present as it happened to me when updating my project to UE4.8. And the Error pops up everytime I reopen the project.

As morph208 mentionned, it is related to a Blueprint using instanced static meshes component.

Hi Genova,

I’ve not been able to reproduce this on my end, unfortunately. I’ve attempted to reproduce on my machine in various ways and have not seen the error message. There hasn’t been much said on how the BPs are setup that are causing the issue and simply using a BP with a ISMC does not cause the error that I can see.

If you have a way of reproducing or can provide a sample project that does this I am certainly more than happy to look into it further.

Do you have a depot or email where I can send you the assets ?

If you upload to dropbox or a similar upload site you can send me the link privately on the forums by sending me a message here: https://forums.unrealengine.com/private.php?do=newpm&u=4894

Thank you!


Hey Tim.

Confirmed migrating the assets in a blank project will still result in the same error.
I sent you a message with the files.

Let me know if you need anything else

Also, two notes :

  1. For some reasons deleting the script in the Event graph and pasting it back will result in the error no longer showing up.

  2. I can’t seem to be able to make the “Update Instance Transform” to work in the Event Graph. But it works in the construction script though.


I’ve just managed to get the time to look into this a bit more and want to download your file, but it wasn’t there. Any chance you can reupload?


Thanks, Genova. I’ve gone ahead and downloaded this, so if you need to pull the link feel free. I’ll look at this as soon as I’m able.

Hey @Genova

I was able to see this result when converting the object to 4.8. However, I’ve not been able to recreate the warning that happens in a more simple way.

I was able to get rid of the issue in 4.8 by disconnecting Event Tick and Delta Seconds wires and reconnecting. When I reloaded the project the warning has ceased.

Opening the same 4.7 project with our internal build of 4.9 no longer produces this error message on my end.

Ah i See.
Ok then that should explain why the Update Instance Transform seem to not work anymore. I’ll try that and see if that fixes both issues.

THanks Tim

Experienced similar issues with 4.10.4 and 4.11.0 preview 6. Interesting fact is that it works while loading my project from C: but fails with the error above if I move the project to D: and try to load from there. Bug report: https://answers.unrealengine.com/questions/383768/error-saving-level-to-drive-d-but-works-on-c.html