[4.8] Instanced Static Meshes scaled down a little after rotate

These empty spaces appear in between my instanced static meshes when I generate my level in 4.8:

It’s fine in 4.7.6:


This only happens when I rotate the instanced static mesh. If the rotation = 0, everything aligns perfectly.
Blueprint for spawning my instances:

If I manually place the static meshes in my level they align perfectly as well. Even when I rotate them.

The things I checked:

  • Rotating the instance afterwards, same issue.
  • Position/Scale/Rotation is all perfect on the instance (exactly what it should be).
  • Models are all 1000x1000 units.

There must be an issue with the transform of Add Instance when you rotate it. Rounding error of scale?

1 Like

Here is a testproject that I made in 4.8 to show the problem.
Test Project

Still having issues with this :(.

Hi Unain,

Please do not bump threads that haven’t gone unanswered for 4 or more days from the last post. This clutters the answerhub and makes it extremely difficult to parse through information and help anyone. I have downloaded your test project and will post back here when I have additional information available.

Sorry for the earlier bumps, didn’t know about the 4+ days bump rule. Any progress on this issue? 4.8 is working amazing so far, but I would like to get rid of this problem.

Hi Unain,

I’m not seeing this error on my end. What Engine Usability Settings are you currently using?

I think you meant Engine Scalability Settings? Those are on Epic.
This is the DefaultEngine.ini that I’m using atm:
Pastebin of DefaultEngine.ini

Can’t seem to get a fresh default 4.8 version when I delete it though.

Hi Unain,

Ah yes that is what I meant! Sorry about that, I haven’t had my coffee this morning! Do you have any steps I can take to reproduce this on my end with your sample project? I attempted increasing the x max and y max as well as the tile size but saw no difference or breaks in the tiling.

  • Load up Testmap.
  • Set Max X and Y to 5.
  • Set Tile Size to 1000.
  • Make sure each instance is rotated 90 degrees on the yaw in the blueprint.
  • Use Simulate (unlit / wireframe shows it best).
  • Select the grid (so you can see the yellow lines in between tiles).
  • Make sure to go close-up.

It looks like this when I load it up myself:
[Lines in between, its a bit big so linked it][1]

In wireframe:


If this still doesn’t work then it must be a setting that I am missing in 4.8. It work perfectly in 4.7.6 though.

Hi Unain,

I have reproduce this and have entered a bug report, UE-17458 to be assessed by the development staff.

Thanks for the help, glad it wasn’t an issue on my side :).
Looking forward to the fix.

I’m also having this issue, just checking in to see what the status of this bug is in 4.8.2 hotfix.

It’s still there in 4.8.2. I haven’t tested the 4.9 preview version yet.

Hi Unain,

This is still under assessment by the development staff. It has been marked as Major but I do not have a timeframe of when a fix will be implemented.

So two years later it is still unresolved and we can’t use instanced static meshes without gap between them?

Yes, problem is still present in 4.13 :frowning:

Here is a work around I found. I also used 1000x1000 tiles.
Basically, if your Yaw rotation is 0, keep normal scale.
If your Yaw is anything else , bump up the scale to 1.0001
I haven’t tested it on Roll or Pitch, or on other sized models.

1 Like

Present still in 4.19

Still present on 4.22

Still in 4.24.2