4.8 Cant load 4.7 Project -linux

As per my thread:
Linux - "package project" takes to website :( - C++ - Epic Developer Community Forums(&p=286009#post286009

Im running the 4. editor, and cannot get my project to compile, so cant even open my project. This is the error log:

The project could not be compiled. Would you like to open it in an IDE to edit source code?

Log: Running /home/linux/UnrealEngine-4.8/Engine/Binaries/DotNET/UnrealBuildTool.exe - Pastebin.com

Your question got thrown to moderation because huge log you pasted, i placed it in PasteBin and posted link. Please use PasteBin or file attachment next time :slight_smile:

Ok, ive tried using the commandline to see if theres anything there that is of use…

Ive tried using the commandline to see if that helps. This is the error log its given me…

link text

Hi there


[31m[2015.05.06-06.11.51:999][ 0]LogCompile:Error: Remapping old metadata key ‘FriendlyName’ to new key ‘DisplayName’, please update the declaration.

Seems to be your problem.

What does this mean? And how do I fix this?

ok made a new clean project and heres the error im now getting. I get the same error on a blank clean c++ project too!

CommandUtils.Run: Run: Took 26.319568s to run UE4Editor, ExitCode=0
InternalUtils.SafeCopyFile: SafeCopyFile /home/linux/UnrealEngine-4.8/Engine/Programs/AutomationTool/Saved/Cook.txt /home/linux/Library/Logs/Unreal Engine/LocalBuildLogs/Cook.txt
InternalUtils.SafeDeleteFile: SafeDeleteFile /home/linux/UnrealEngine-4.8/Engine/Programs/AutomationTool/Saved/Cook.txt
Project.Cook: ********** COOK COMMAND COMPLETED **********
InternalUtils.SafeFileExists: SafeFileExists /home/linux/Documents/Unreal Projects/DogFight/DogFight.uproject=True
Project.CopyBuildToStagingDirectory: ********** STAGE COMMAND STARTED **********
BuildCommand.Execute: BUILD FAILED
Program.Main: AutomationTool terminated with exception:
Program.Main: Exception in AutomationScripts.Automation: Missing receipt 'DogFight-Linux-Developmentx86_64-unknown-linux-gnu.target.xml'. Check that this target has been built.
Stacktrace:   at Project.CreateDeploymentContext (AutomationTool.ProjectParams Params, Boolean InDedicatedServer, Boolean DoCleanStage) [0x00000] in <filename unknown>:0 
  at Project.CopyBuildToStagingDirectory (AutomationTool.ProjectParams Params) [0x00000] in <filename unknown>:0 
  at BuildCookRun.DoBuildCookRun (AutomationTool.ProjectParams Params) [0x00000] in <filename unknown>:0 
  at BuildCookRun.ExecuteBuild () [0x00000] in <filename unknown>:0 
  at BuildCommand.Execute () [0x00000] in <filename unknown>:0 
Program.Main: Missing receipt 'DogFight-Linux-Developmentx86_64-unknown-linux-gnu.target.xml'. Check that this target has been built.
Program.Main: AutomationTool exiting with ExitCode=1

link text
link text

You are missing the receipt file. Make sure that you invoke BuildCookRun with -build parameter, since the receipt file may not be generated otherwise.

(When combined with -clean, this will recompile your binary).

There are a few problems in the logs posted here. First there’s some blueprint error that prevents cook from succeeding (this is not Linux-specifc):

[2015.05.11-16.16.07:396][ 0]LogInit:Display: LogBlueprint:Error: [compiler BP_CloudVolume] Error Could not find a function named “GetScalabilityQuality” in ‘BP_CloudVolume’.

Second, when you invoke BuildCookRun command of UAT, make sure that you pass -build. Passing both -build and -clean should be a safe bet.

awesome, looks like the -build command was what was missing :slight_smile:

Now i can get in there and fix it up!