Download

4.8 can no longer import just the FBX Animation Skeleton ONLY, imports fail everytime.

This is a new headache, I’ve been importing my FBX files (exported from blender) into UE4 just fine…until 4.8.

My FBX files that are only animation use to import without problems, because I could tic the “import as skeletal” I could import the animation without problems.
But now, the import fails every time, and I can’t get any animations imported anymore:
UE4.7 import options.png

The menu doesn’t change options like it use to do, like it doesn’t know that it’s just an animation.
UE4.8 import options.png

Here is my FBX:

I can still import it in 4.7.6, but it doesn’t import in 4.8.0

(I should add that the file was exported from blender 2.74)

Hi there,I have the same issue and I can’t import any kind of animations, and I’m going out of mind…
Did you find anything (like a hidden menu or a voice that isn’t checked) that can help us to solve this problem?
In the previous version i can import the animation, but in the newest version 4.8.1, with the same settings, I can’t do this…!

I have exactly the same issue with 4.8. It worked fine in 4.7.6.

What should be done to get it working?

I think I bumped into that error once with 4.8 when the skeletal mesh already existed in the project. I deleted my mesh and started the import process over again and was fine.

I exported from Blender using Binary exporter. first mesh and skeleton in one file, then only armature in export settings for the animations.
Imported the first file as a skeletal mesh, unchecking animations in UE4 importer.
Imported all animations at once just fine.

The way I do it in 4.8 is to UNcheck “import mesh”.

That brings up the old skeletal-selection animation importer view.

I think the animation system needs to be redone. The animation pack that is free in the marketplace is not compatible with the 3rd person blueprint Character, even though the characters are the exact same.

I can confirm this issue. Having the same problem here with Mixamo’s FBX files.

Hi everyone,

(posting the same message as here: Failed to import animations Blender -> UE - UE4 AnswerHub )

Can you walk me through what steps you are taking to reproduce this on your end? Here is what I did in Blender 2.75 rc:

  1. Create a box with 1 bone
  2. Export box and bone fbx
  3. Import to editor as skeletal
  4. Create an animation in blender (I used a simple rotation animation to test)
  5. Export just the baked animation from blender
  6. Import the baked animation, target the imported skeletal mesh from before

At this point, I did not get any warnings about my skeletal mesh or any import errors related to this. Are you doing something differently than I did?

I installed 4.7.6, was able to import everything, then just migrated it my to 4.8.1 project.

Dammit! I’m still having this problem!

I followed your instructions exactly, but I still can’t import my FBX animation files

In blender, I’m exporting using FBX 6.1 ASCII

I can’t use FBX 7.4 binary because of the endless scale issues that it causes, that’s why I switched FBX 6.1 but it seems to be deprecated by UE4.8x now.

I’ve even upgraded both blender and the unreal engine, and I’m still getting this exact problem as described above.
I’m currently using Blender 2.75a and UE4.8.3

…I just want to put my animations in the game T_T

u have to export Bones Only. In 3ds max (thats what i use) select bones and press export selected.

That’s what I’m already doing. That’s why this glitch makes no sense :frowning:

I selected only the bones
Then in the Export settings, tic on “Selection Objects”
Then I enable “Armatures” and disable all the other categories
Then I tic on “Animation”
Then Export to FBX 6.1 ASCII

For what ever reason, Unreal swears that there’s a mesh and tries to import one (despite one not existing) I can’t make it ONLY import the animation. It’s like it’s failing to auto-detect that it’s only an animation, this wouldn’t matter if I could tell it that there’s no mesh.

This is unique to 4.8x of UE4, 4.7 didn’t have this problem.

Then Export to FBX 6.1 ASCII

Unreal engine 4 supports FBX 2013.3 and higher. Maybe there is the issue?

I’ve just tested this importing an FBX animation only. Just to be clear, you will see the following menu as if it’s prompting you to import a mesh. However just select the skeletal mesh in the skeleton menu and the animtion will import applied to your previously imported skeletal mesh. (You must have one compatible skeletal mesh to apply the animation to, otherwise it will not import.)

0ce678698bbb37d2855491e569cfe7c08ebbf253.png

If this does not resolve your issue, please post screen shots of any pop up windows or errors you get when trying to import your FBX animation.

That’s the 4.7 dialog box, it doesn’t show up anymore in 4.8x when importing FBX 6.1 ASCII

Here are my export settings:
EXPORT.png

Below is what happens when I try to bring that into UE4
Despite not having the same dialog box that I use to have in 4.7, I still select my previously imported skeletal mesh when importing, it’s the same one that’s been in my UE4 project this whole time, that I’ve always selected to import my animations to. It simply doesn’t work anymore.
Here are the screens of what use to happen, compared to what happens now:

I select the skeleton from my project just like I’ve been doing in 4.7
But only now in 4.8x I get the error message screened above.

I’m doing exactly as instructed, it’s just not working anymore. I don’t get the same import options when importing FBX6.1ASCII, my import menu is different from yours now in 4.8x.

I got my skeletal mesh and animations to import just fine from Blender 2.75a. Everything imported in one shot. Make sure when you export from blender, in the FBX export, you have mesh and armature both selected. It worked for me.

WOW THAT DID IT!!!

It’s still odd, because exporting the FBX (6.1 ASCII) animation AND mesh was never a requirement just to import the animation into 4.7 before?
Strange that it’s required now, this makes my exports huge though because the mesh has to be in every file now.

Anyway, THANK YOU! :smiley:

Cool. Glad to hear. I guess I am learning. I was actually able to help someone.

Feels good.

Aaron

The mesh doesn’t have to be in every file. I’ve never had to do that. Try using this tool: https://forums.unrealengine.com/showthread.php?34619-ADDON-BLENDER-UE-Tools&highlight=blender+tools. It has everything already set up, one click and you’re done.

Also check this out: https://krisredbeard.wordpress.com/t…-player-model/.

I always do the ‘comment’ out thing listed in the above link first off when I download Blender for working with UE4. It solves 50% of the headache of getting a mesh to work between the two.

Glad to see that you have got this working. Just to clarify to others who may be following this thread to resolve their own issues, this is a 4.8 dialog box that you will see if you are importing an animation only without encountering any issues:

FBX.png