4.8 Build error ( On default scene) runUAT.bat error

Hi,
I just tested my project in 4.8 (the 4.76 build is fine) . I installed Microsoft Visual Studio (4.8 asked for this) , which seemed to install fine. I am now unable to build and get this error log, any Ideas?

MainFrameActions: Packaging (Windows (64-bit)): RunUAT.bat ERROR: AutomationTool was unable to run successfully.
MainFrameActions: Packaging (Windows (64-bit)): BUILD FAILED

Thanks in advance , Greg

**I also tried this on a fresh default scene ( 3d scroller template) It failed to build as well
I have attached the log:
link text

I am not sure this is related but the Launcher folder gets blown away when I do a build? Is this normal ? Keep in mind I am only trying to build a default scene with 4.8 before I migrate to it!

Hello,
Have you the latest version of the 4.8 or the preview?
I had the same problem and when i updated it works.
Have a good day,

Hey Renderdog-

What were you using to build your project prior to installing 4.8 and Visual Studio? Do you get the same build error if you create a new project and try to build it? Additionally, when building the project make sure your solution configuration is set to DevelopmentEditor rather than Development.

Cheers

Doug Wilson

Hi Doug,
I have attached an image showing the steps I am taking. Prior to Unreal 4.8, I was using 4.76 to do test compiles of my project. I was not using Microsoft Visual Studio at all. I installed it when Unreal 4.8 required it’s installation.
My test today:

  1. Verify 4.8 install
  2. Launch 4.8 , create a new blank project
  3. Follow the steps in the image
    Result = failure to compile a blank project.
    Any help would be appreciated. I am happy with 4.76 but would love to be able to use 4.8

Hi Doug,
Yes, a completely new “blank” project generates generates the exact same error.

Hey Renderdog-

Can you check your launcher to see if you have the Substance Plugin for 4.8 installed? You can do this by clicking on Installed Plugins under the 4.8 launch button in the Library tab of the Launcher. If you do have the Substance plugin you may need to remove the plugin/disable it inside your project and then try packaging your project again.

Cheers

Doug Wilson

Thanks Doug!

I completely removed the substance plugin. My default scene and current project compiled properly.

Thanks for your help, very much appreciated.
Greg Notzelman