4.8.1 Issues with steam servertravel

We cannot seem to get all clients to move with our server to the next level through steam. It also causes the clients to go back to the start menu and they are unable to rejoin as they seem to still be in that game session.

We are using the servertravel console command through blueprints.

The current system was working through our network on 4.7.6 before we set up our game for steam. Is there anything else that has to do with servertravel specific to steam or do we need to get in touch with steam and set something up?

Hi, does “servertravel” UE4 command or steam? Can you show screenshot of blueprint how you use this? Maybe you need custom event and replication “multicast” or try use blueprint’s “openlevel” with custom event and replication “multicast”.

servertravel is a UE4 command and it should pull the clients with the server when called. It can be call through the command console or through C++.
Open level just opens a new level without any network commands. you can add a ?listen to it to create a listen server.
Multicast openlevel will separate everyone into there one instance of the level.

Are you testing in the editor, or a stand-alone game? I have had this issue in PIE, but once I ran in a standalone game, server travel works fine.(Only tested with restartgame()), otherwise I cant join sessions while on steam for 4.8.1.

Fixed it make sure you have seamless travel turned on in your gamemode!

UWorld::ServerTravel | Unreal Engine Documentation there’re a lot of parameters, did you try change them?

epic’s stuff wrote here about bug report in jira with servertravel ServerTravel doesn't work on 4.7 editor - Programming & Scripting - Epic Developer Community Forums and probably bug happen again, i think you should report it on forum https://forums.unrealengine.com/forumdisplay.php?24-Feedback-for-Epic