[4.8.1] Audio Components ignoring Start Time set by Play node on Android

I’m seeing an issue on Android when playing a piece of music with an offset in Blueprints. My in-game music has half a second of silence at the start of it, so I want to play it with a Start Time of 0.5. This works fine on PC, but not on Android; the music just plays from the start. If I specify a Start Time for the title screen music, which plays as soon as the game starts, the same thing occurs. However, this offset seems to be working elsewhere in the game. My music is assembled from various 15-second segments, and I have two audio components which I switch between (This was a work-around for timing issues).

All of the pieces of music have half a second of silence at the start of them, and when I play the second piece, the offset works fine on both Android and PC. I thought this might have been because the offset on the first piece is specified in the Play node itself, whereas at the offset on the second piece comes from a variable that is plugged into the Play node, but when I tried plugging a variable into the first piece, it still failed on Android. I’m stumped!

Hey GiraffeCat,

Would you mind providing me with some images so I can reproduce your set up on my end?

Could you also provide me with type of Android Device you are using?

Thank you,

Hi Andrew,

For the sake of my sanity, I tried to reproduce the issue in Tappy Chicken. I imported a piece of music (Stereo .WAV, 44.1 KHz), and added it to the BP_MainGame blueprint as an Audio component (And made sure to untick the ‘Auto Activation’ flag). In the ‘Initial Setup’ section of this blueprint’s event graph, there is a timeline for animating the title screen; I added a play event to the Finished pin of this timeline, to play the music with an offset of 7 seconds once the animation has finished. As before, this offset works on PC, but not on Android. Here’s a screenshot of the blueprint:

I’ve seen this issue on an LG G3, and a Samsung Galaxy Nexus.

Hope this helps!

Hey GiraffeCat,

Thank you for the visual test/clarification. I will return tomorrow to test this on my end on a similar device you mentioned. If you discover any new information before I begin my testing, or if you have additional questions let me know.


Hey again GiraffeCat,

I appreciate your patience while testing/verifying this issue. I was able to confirm your report and entered a bug for the issue UE-18686. I currently cannot say when a fix for this issue will be integrated, but we ask if users are looking for updates to their issues to look at the full Release Notes on our Documentation pages found below.

Release Notes Search