[4.7 Preview 5] Standalone game BP compile issues

Launching a standalone game in 4.7 Preview 5 crashes my project (crash dump, logs attached). This is the binary version installed from the Unreal Launcher, the project was converted from 4.6.1.

Inspecting project log reveals that several blueprints failed to compile because the target input node was found to be invalid. Three types of invalid target nodes are observed:

1) Nodes with Array operations

Log excerpt:

LogBlueprint:Error: [compiler] Error The current value of the ’ TargetArray ’ pin is invalid: Array inputs (like ‘TargetArray’) must have an input wired into them (try connecting a MakeArray node).

Related nodes:

2) Nodes which invoke a function on the reference of a blueprint object instance

Log excerpt:

0]LogBlueprint:Error: [compiler] Error This blueprint (self) is not a BP_ReproSiteBase_C, therefore ’ Target ’ must have a connection.

Related nodes:

3) Nodes which invoke a function on the input parameter of a function (and reference of a blueprint object instance)

Log excerpt:

0]LogBlueprint:Error: [compiler] Error Variable node Get Faction Name uses an invalid target. It may depend on a node that is not connected to the execution chain, and got purged.

Related nodes:

a)

b)

These blueprints compile without any issues in the editor and in previous versions of the engine these also worked perfectly in standalone game mode.

I consider this a somewhat serious bug as it is becoming a pattern for projects to not work in standalone or shipped modes due to some quirk or catch. To elaborate on this comment, standalone game did not work in 4.6 either because of [this bug][6] which affected many projects and required one to build the engine from source and apply a local fix to event dispatcher code. Just to want add that I really appreciate the hard work Epic puts into each release, just want to point out that standalone/shipped builds often tend to have these quirks that are often very difficult to reproduce.

I’m not able to reproduce this bug in the standard templates or Epic’s samples. Let me know if you need any further information to investigate this bug!

UPDATE: I just downloaded 4.7 Preview 6 and tested it there, the issue still persists and the logs display even more errors than the previous build. Quite worryingly the major 4.6 standalone bug for dispatchers that I alluded to earlier appears to have regressed again in this build! (see first section of log excerpt below)

I’ve attached the logs for Preview 6 for comparison.
link text

Here’s a quick excerpt of the new errors that weren’t present in Preview 5:

[2015.02.12-13.08.04:829][ 0]LogBlueprint:Error: [compiler] Error No delegate function ‘’ PollinateEvent
[2015.02.12-13.08.04:829][ 0]LogBlueprint:Error: [compiler] Error Event Dispatcher has no property Bind Event to Interaction Key 2 Held (Timed)

[2015.02.12-13.08.04:779][ 0]LogBlueprint:Warning: [BP_PolliPlant] CreatePinForVariable: ‘PolliPlantInRange’ variable not found. Base class was probably changed.[2015.02.12-13.08.04:779][ 0]LogBlueprint:Warning: [BP_PolliPlant] RecreatePinForVariable: ‘Output_Get’ pin not found

[2015.02.12-13.08.04:813][ 0]LogBlueprint:Warning: [compiler] Warning Type mismatch between pins Pollinator and Pollinator
[2015.02.12-13.08.04:814][ 0]LogBlueprint:Warning: [compiler] Warning Type mismatch between pins Target and Pollinator

[2015.02.12-13.08.04:820][ 0]LogBlueprint:Warning: [compiler] Warning Could not find a variable named “Pollination In Progress” in ‘BP_PolliPlant’.
Make sure ‘BP_PolliPlant’ has been compiled for Set Pollination In Progress

[2015.02.12-13.08.04:820][ 0]LogBlueprint:Warning: [compiler] Warning Could not find a variable named “Pollination In Progress” in ‘BP_PolliPlant’.
Make sure ‘BP_PolliPlant’ has been compiled for Set Pollination In Progress

One more piece of information - In Preivew 6 I also get a huge number of map check errors (1419) pertaining to ‘externally referenced’ map components. These weren’t present in earlier builds. While I’m not sure whether there is some relationship between these errors and the target link of nodes being broken in standalone mode, in preview 6 I do get an explicit error while launching standalone mode that alerts me about these map check errors.

Hi VSZ,

Was this setup was working correctly in 4.6?

Also, 4.7 Preview 7 is out now. Could you try to see if the error is still present there?

Yes the setup was working perfectly in 4.6, with the exception of the widely reported [4.6 standalone bug for dispatchers][1], which required a local fix/rollback of certain scripts (listed in that link) to fix the issue. Post 4.6. subsequent builds of Unreal had resolved the standalone event dispatcher issue until 4.7 Preview 6, where it appears to have regressed back. The other issues in this report (viz items i. ii. iii. in my original bug report) have been reproducible for quite a while (as early as Preview 5).

I just tested Preview 7, it yields the same results as Preview 6. I’m attaching an image of the map check errors in case it provides a clue. These map check errors only started showing up after Preview 6 (Preview 5 did not throw a map check error although items i) ii) iii) in my report were still reproducible there ).

I have the same exact problem

Hi TJ Ballard, just checking whether you had a chance to investigate this issue.

@sanford87, thanks for reporting, I was worried I was the only one with this bug :P. Just to be sure are you facing both the standalone game issue and map check errors (possibly related) or just the standalone game issue?

I’ve been trying to get a repro of the issue but so far I haven’t had any luck. Could you try this in Preview 8? If the issue is still present (which I suspect it will be), could you post a test project that has this error?

I’m afraid I’ll have to give you my actual project. I tried pulling just the problematic assets into a test project but there’s many interdependencies that end up creating false flag issues.

What’s the approved way to share my project with you? As this is my actual dev project that I’ve been working on for ages just want to be extra sure of the recommended process :slight_smile:

The preferred way is to upload your project to Google Drive, Dropbox, or other (as long as it’s reputable) and send me a private message directly over the Forums with the download link.

https://forums.unrealengine.com/

Thanks, I have sent you a PM with the project.

With preview 8 the project at least doesn’t crash in standalone game any longer, although the compilation issues still persist (so objects of affected blueprints are not spawned in standalone game).

To reproduce run my project in both ‘Play In Viewport’ and ‘Play In Standalone Game’ and compare the results. For the latter many game objects disappear and the logs contain the snippets I’ve posted in this thread. The logs also contain a large number of deprecation, accessibility warnings which I haven’t fixed yet (these were not present early 4.7 builds but I don’t think they’re causing the issue in any case)

Hi VSZ,

Thanks for sending me the project, I was easily able to reproduce the issue. I’ve entered this as JIRA UE-10283 in our system and the developers will be investigating it further.

We’ll post back here as soon as we have an update.

Cheers,

TJ

Hurray! Thanks so much for finding the repro.

Hello! Are there any updates on this? It seems that all the errors from above happen in 4.8.0-source built release as well.

Although I am struggling with incomprehensible circular dependencies within my UMG Blueprints, yesterday the Blueprints went fine! Today I started the engine and many node connections were disconnected.

All following pins are of class BP_SectionContainer used in different Blueprints.

In Macro Library used in BP_PlayerController:

In BP_SectionContainer:

In BP_SectionContainer:

All following pins are of class BP_Section inheriting from BP_SectionContainer.

In BP_PlayerController:

Right now that I made the screenshots I realized that the error must lay in BP_SectionContainer, because it compiled fined yesterday. Is it possible that you cannot use a variable of your own type from within another class (here from GetHUD->SectionContainerReceivingInput (is a BP_SectionContainer)) somehow?

Hello Kalabrix,

The issue that is listed on this thread that was reported by TJ Ballard has been resolved. As for the issue that you are experiencing, I have a few questions that will help narrow things down.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide steps to reproduce this issue on our end?
  3. Was the project that is experiencing the issues upgraded from an older version of the engine?

Hello Rudy,

After implementing all the functions and variables I needed, the issue described above is gone (for now?). I think its gone partially and came from a not completely working Blueprint with re-parenting work to do and the following issue (which may help to understand).

I still have the structure:

49019-class+inheritance.jpg

The widgets theirselves are arranged in UMG like this (Sections can be encapsulated differently):

49031-umg+inheritance.jpg

BP_SectionContainer contains a function called “RegisterSections” which is overridden in widgets like “MainMenu_Container” or “MainMenu_Frontpage”. And anytime I compile BP_SectionContainer or BP_Section, I also have to re-compile all widgets manually which override that function. Widgets which do not override are left alone.

BP_SectionContainer has a variable array “Ref” to reference BP_Sections. In the overridden function I fill it with the Sections which are encapsulated in UMG.

49032-registersections.jpg

Then the parent of “MainMenu_Container” - BP_SectionContainer - uses “Ref” to do some minor things.

I tried to reproduce it with a really small Blueprint setup but could not get the issue. And yes the project was upgraded from 4.7.2 to 4.8.0 but the Blueprint functions have been implemented after upgrade.

Hello Kalabrix,

I am happy to hear that you have your project working and that the issue is no longer occurring. I will be sure to apply any pertinent information from the information that you have provided above and apply it to the report. If the issue happens again please feel free to reopen this issue with additional information on how to reproduce it on our end. Thank you for your time and information…

Make it a great day