[4.7] Editor Lags Mac

Hello,

On 4.7 newest version everything is pretty laggy on mac. I think mostly everything that has to do with viewport.
4.6 was much better.

Hi Footman,

Can you give us your system specs, please? Thanks!

Hi Footman,

Are you still experiencing this lag in 4.7 Preview 5?

Hey,
It is better now but still not as smooth as windows on same machine. Generally Mac version is not as stable as windows.

Would you say it performs at least as well as 4.6.1 did on the same machine?

For reference, these are the specs you mentioned in another post:

Mac OS 10.10
MacBook Pro (15 Zoll, Anfang 2011)
12 GB 1333 MHz DDR3
AMD Radeon HD 6750M 1024 MB

It’s an older system so it may struggle on Epic settings. Have you tried lowering the engine scalability settings? It may also help if you turn off Realtime in the Viewport settings.

Well, we like to be moving forward, but at least we’re not moving backwards. I’m going to mark this post as resolved, but I’ll also let the Mac devs know that you’re experiencing different performance based on OS on the same machine.

Yes, please open a new thread for the lighting build issue. It sounds familiar, but I’ll make sure we look into it for you. It may not be til after the weekend, unfortunately =/

Hey Ben,

Yes i think it performs like 4.6.1 now.
Yes i know it is an older system. I know that low quality settings help.
I have bootcamp windows on the same machine and it works smoother for me with the same configurations (only 4.6 compared).

By the way i have problem that I cant build lightning on mac 4.7 (on windows 4.6 yes). It stacks on 0 %.
I have build “UnrealLightMass” project in Xcode. Should I open extra thread for this?

Hey,
Thanks. I solved lighting issue by deactivating firewall.