4.7 Can't install

When I try to install 4.7 it downloads to about 25%, then my laptop bluescreens. I had no issues running 4.6. Is there something drastically different with 4.7? I’ve tried about 5 times now with the same result each time. I removed 4.7 and tried to redownload, and I completely uninstalled the launcher and reinstalled using the latest installer. Any help would be appreciated

I dont think this is caused by the engine or the launcher alone so can you please check the dump files using a program like this? BlueScreenView - Free download and software reviews - CNET Download

The files it finds can tell you what is causing the BSOD(maybe GFX driver or hardware related.)

Hi Jacky, Thanks for the advice.
I ran bluescreen view and it came up with ntoskrnl.exe as the cause. I ran tests on my RAM and hard drive and didn’t find any errors. I also tried updating my graphics drivers, then completely removed and reinstalled them. Still no luck. I’m going to try going back and installing 4.6. I never had issues until 4.7

4.6.1 installs without a problem. Is there a substantial difference in the install? I was able to put 4.6.1 back on but 4.7 still gives me a bsod

Ok, I managed to stop getting a BSOD. Now when I try to install, it goes to about 12% through verification then the launcher closes with no error message, everything disappears from my desktop and nothing will respond. I can’t even run the task manager. It says task manager can not be found when I try.

Is there a log file I can check to see where things are getting stopped?

Hi TheWhale,

Here are some troubleshooting steps to try and if nothing works you can generate a Debugging log.

Could you post the Debugging log here as well as your dxdiag (system specs)?

Sorry for not responding. I finally fixed the problem. My hard drive was slowly dying. It would pass tests, but then I started getting more and more bluescreens. I replaced the drive and now I’m able to install without issues. Thanks to the folks who helped!