4.7.6 - test project stuck on splash screen on iOS 8.3

Hello - while using 4.7.6, when I build a test project (or the Blackjack or Tappy Chicken sample projects) for iOS and deploy the IPA to my iPhone 6 (running iOS 8.3) the app hangs on the splash screen. When using 4.5.1, I don’t have this issue, though I only tried the Blackjack sample project with that version. I couldn’t find any other reports about this - Is this a known issue? Thanks for any help.

Howdy 0cme,

Thank you for reporting this issue that you have been seeing. I am going to need a bit more information before I begin digging into this issue. Would you be using the Binary or Source version of UE4? Also, Have you tested this issue on any other devices? Would you be deploying from a Mac or from a Windows machine?

Any additional information would be greatly appreciated.

Thanks and have a great day!

Hi - I’m using the Binary version on a Windows PC, Windows 7 SP1. When I test Blackjack or Tappy Chicken on the PC, I don’t have the same issue - the game proceeds to run normally. I’m afraid I don’t have any other devices available to test on right now.

(One other note - I’m deploying to the iPhone, I’m adding the app to iTunes and syncing it, since I’m having a separate issue using the automation tool. This process results in games that run correctly when using 4.5.1, though.)

Thank you for the information 0cme!

I have attempted a quick repro of this issue and have been unsuccessful with a reproduction of the splash screen failing. I tested this on an iPhone 6 on OS 8.3 with the BlackJack project. Would you be able to send over your build log files? If you use Launch on, are you experiencing the same issues?


I get the issue if I use Launch on, and then copy over the IPA (through iTunes) from projectName/Build/iOS, which I was doing since the automation tool wasn’t starting it automatically. I’m attaching a log from that if it’s helpful. [log][1]

However, if I use File → Package Project → iOS, and copy over that IPA, then it works! So this isn’t an issue anymore. Thanks for your help, and sorry I’m still an Unreal n00b. :smiley:

40635-blackjack.txt (696 KB)

Hey Ocme,

Glad to hear that you have resolved this issue that you have been seeing. A launch on build do not fully package the project. It packages a smaller version of your project so that it can be tested. If you happen to run into this error in a later build of UE4, be sure to comment here so that this issue may be reopened.

Thanks and have a great day!


I’m having this issue in the 4.8.2 version of the engine.
I can deploy the game to my phone (), but when i start the app it shows the splash screen and then it shuts down.

I’m going to test if a packaged version works now.


Hey JGI,

Have you upgraded your engine to 4.8.3, if not, please do so at this time and try again. Could you also tell me what version your is on? What template are you pushing to your device? Please try a regular template from UE4 so we can tell whether or not it’s project specific or not.

Thank you!

I have a similar issue on Windows 10, iOS 8.4. I am using the latest engine source from gitHub.

After remote building successfully, the app is installed onto my iOS device. When I launch it, it stays on the splash screen and never proceeds to the game. I tried packaging to an IPA, and a number of combinations of packaging settings, and then adding through iTunes but the same issue occurs.

I had this issue with the binaries version 4.8.3 which was solved by making sure the default game map is set to something, but since then I’ve changed to the source version so that I can build to iOS with 3rd party plugins enabled. I’ve checked to be sure that I have my default maps and modes all set in the project settings.

I’ve also tried the project launcher with on the fly and by the book configurations, neither of which make any particular difference.

Hey GCRev,

I am currently looking into this issue that you’re explaining. Could you please provide me any that you may have from your project or device? Any additional information is greatly appreciated.

Thank you!

I figured out what the problem was, or at least, what I thought the problem was. One of the 3rd-party plugins I had enabled was not included in the [project].Build.cs dependencies section. I got build errors in visual studio when I tried to include it. I disabled the plugin in the project manager and now the game works.

Long story short, it was a dependency issue. The log may or may not have pointed that out, but I doubt it because the build would still succeed.

I’m glad that you figured the issue was one of the plugins. If you run into any further issues, feel free to post a new question to AnswerHub.

Have a great week!