[4.7.6] Player Controller rotation doesn't update with Root Motion Rotation and Input Yaw Disabled

I have a character that I’m using Root motion and rotation on.

To use root rotation I need to turn the “Use Controller Rotation Yaw” off on my player (good). But when my character rotates with the root motion, the Controller rotation doesn’t update with it. I have to manually script the Controller to follow.

It seems like the Controller rotation should match even if the “Use Controller Rotation Yaw” is off. I can’t really think of a reason to not have it update…at least right now.

Hey ,

Since this is building off of a prior issue, would you be willing to send me your project so I can see for myself how you’ve got everything set up? You can upload to Google Drive, Dropbox, etc and PM me on the forums with the link.


Marking this as answered due to inactivity. Simply respond to re-open the issue.


Hi . Had some time to get test assets together.

I’m using a lot of the stock FPP Epic assets, with one new animation and an edited player BP.

Some backstory: I’m trying to find an elegant way to make first person cutscenes that take complete player control away and use root movement + rotation a bunch.

Note: Right now I’m switching to a ‘cinematic’ camera under a duplicate of my regular FPP mesh. The camera switches upon the triggering of the cinematic – in this case, the “P” button.

When the player hits the button, I’m switching cameras to the cinematic one, turning off inputs and a bunch of other root-motion friendly things. At the end, I’m setting the value for bIsTurning which is read into the AnimBP to actually play the root rotation anim.

During play, I’m printing the Capsule and Controller rotations. When the root rotation animation plays the Capsule rotation updates with the animation rotation, but the controller does not.

It’s not difficult to update the Controller after the animation finishes, but I’m thinking that the Controller should update with root rotation which might avoid headaches for other users in the future. Or if there’s a particular reason it does not update by default, that is cool too :slight_smile:

Sorry for the delay in response. I have sent an email to some of our engineers to confirm whether this is a bug or expected behavior.


Hey ,

So the response I got was that this is not an ideal behavior for most situations. As such, scripting in the behavior is the intended method.


EDIT: If you’d like to share the method you used to script in the behavior for anybody else with this problem, feel free to write that up. :slight_smile: