[4.7.6] Missed collision if pivot outside of collision volume

Hi there,

I have a model with it’s pivot point outside of his mesh (and therefore outside of it’s generated simplified collision):

The reason of this is, that it’s part of a compex FBX import which is split up to several meshes. That’s important for me, because they align to each other as childs with relative location of 0/0/0 (so the wheels, the seats etc. will be at the right place when they are parented to the car’s body.

The problem: When I start the game, the mesh falls through the ground.

That happens even, if I attach a wheel to the parent with it’s own collision volume so that the wheels colider is clearly below the pivot point of the parent mesh:

(The wheels pivot point is in the same place as the one of the car, so it perfectly aligns at 0/0/0).

The car’s body has ‘simulate physics’ and ‘enable gravity’ set to TRUE, these are the collision settings:

When I put my whole car together (all other meshes all child of the car’s body with no offset and auto-weld enabled), they all stay on ground but the car body itself is still falling through the ground:

I can temporality fix this by manually stretching the collision volume of the parent body over the (guessed) position of the pivot point inside the static mesh editor:

As soon as the outer limits of the collision mesh is below the pivot point, the model stops falling through the ground (but is floating in air now, of course):

As soon as the collision volume ends above the pivot point of the mesh, the model falls through the ground.

The really strange thing: When I place a small obstacle below the car in the air, the collision works as expected (it first colides with the obstacle and then falls down to the ground and stays there):

What is going on here?

Hi ,

Using the basic meshes and while using the car mesh you provided in another question you posted a couple of days ago with Trace Complex I was not able to reproduce this.

Here is a video just showing the collision, the mesh pivot (I moved it in 3Ds Max to be below the car), and I use the command PXVIS Collision to view the collision in game to see what’s going on.

I’ve test this in a blank project with no issue and with the Blueprint Office as it looks like you’re doing in your images above.

Two things:

  • Can you try this in a blank project with default settings for everything and let me know how it goes? BP office is probably not the best example because none of the meshes have collision. There are multiple blocking volumes placed around the map instead of collision. I even tested with a blocking volume and it still collided in a manner I expected.
  • In the Static Mesh Editor you do not have to guess where the pivot is. You can use the button in the toolbar for “Pivot” and it will give a visual representation of it’s location for you. :wink:

Let me know.

Hi ,

once again, many thanks for your good support.

My god, forget everything I was saying about pivot points, collision volumes and such.

As your video clearly shows that the core issue must be something else I just made a whole bunch of more tests. And when I deleted absolutely everything out of my level except the mesh and the floor, it still disappeared. I just couldn’t reproduce this outside of my own testlevel and make a small test project for this.

In almost complete desperation I just moved the whole level a few units upwards - and the mesh landed on the floor as it should. WTF.

To make it short: The problem was a default ‘kill-z’ setting of zero. But my floor was a few units below that. The mesh didn’t fall through the floor, it just got killed by this setting.


Solution: Changed the ‘kill-z’-setting in the world details to -1000 and everything was fine.

Many, many thanks. I already saw the edge of madness…

No problem. I’m glad you’ve got it resolved at this point. :slight_smile: