[4.7.6] Dynamic Font Size

Changing the font size on a text widget will not update if dynamically set at run time.

I tried this in a blank project, same results, this was my setup:

DiffHUD Designer:

I made a widget to be used as a HUD, it contains one [Button] 100x100 (CFont) and added a [Text Block] (AText) next to it with the content text as displayed.

DiffHUD Graph:

On the graph I made a quick functionality for the button to update the slate font info.

Pushing the button returns to the screen the proper Font Size, (22, 20, 18, etc…) but the actual text in AText will not update to reflect the changes.

Hello Justin.Dooley,

After doing a bit of digging I have found that this is a known issue (UE-9181) and that it has been sent to the developers for further review. I will provide updates with any pertinent information as it becomes available. I will also be sure to bump the community interest for this issue. Thank you for your time and information.

Make it a great day

Hey Rudy!

Haven’t seen an update to this yet. Is a solution in the works for 4.9?

Hello Justin.Dooley,

I went ahead and double checked on this issue for you. It appears that this issue has not been updated to fixed as of yet. There is not a current time frame in place as to when a solution will be available. Have you tried using a scale box to dynamically change the size of your widgets?

Using a ScaleBox took some “fine tuning” to get it behaving appropriately with text scaling, but in a pinch it got the job done :stuck_out_tongue:

Thanks for the update Rudy, keep us posted if anything changes on this subject :slight_smile: