[4.7.6] Cannot set focus to child actor component in viewport

Hi there,

A short one:
When I click on a child actor component in viewport of blueprint editor, it doesn’t get focus like it’s case with other components. It has to be selected by hand in list each time.

Hey ,

Thanks for report! I can reproduce this in 4.7.6 as well as our internal build, so I’ve entered a bug report (UE-16688). I’ll let you know when I see an update on it. Thanks again!

Besides you cannot focus and are unable to access variables of child actors in blueprints it also results in horrible performance within editor. It is unworkable. Could you add this to bug report? Thanks in advance and kind regards.

That would be a separate issue. Can you create a new post for that? Also, I would recommend testing in 4.8.0, which was released today, to see if there’s any improvement for you. Thanks!

Especially search field is often painfully slow, yes.

Thanks for your reply, I will create a new post for that, . FYI 4.8 crashes consistently with child actors.

What is status with this bug? its still not letting me select child actor components in viewport in 4.12.5


Here is link to issue on our public tracker: Unreal Engine Issues and Bug Tracker (UE-16688)

Hi ! I see issue is marked fixed since long ago. However I do still have nearly same error on my project currently running on 4.20.3.

I cannot select any child actor in world outliner. focus automatically goes on parent actor. I can still open it in Blueprint editor with “Edit” link though.

Would it be a regression ?