[4.7.5] "Trace complex" has no effect on line trace

Hi there,

I want to trace a model with other components inside the simplified collision model of the parent (the wheels of a car which will be attached later). Here you can see the static mesh with it’s simplified collision model:

(Name: SM_car_srt10_no_wheels)

My setup is like this:

This is the result:

As you can see, the line trace nevertheless blocks on the simplified model of the car model and thereforce not detecting the wheel of the car as it should by using the complex model.

If I force the mesh manually to use the complex collision model as simple, it works as expected (but that’s obviously not a desirable solution for physics etc.)

Could it really be, that the flag “trace complex” has no effect at all?

Hello…? Do I something wrong or is this a bug? Thanks.

Hi ,

At the moment I’m not able to reproduce this with anything I’ve setup. Would you be willing to send a simple test project with this?

Hi ,

thanks for investigating. I created a small test project:

Project files:

This is the simplified setup of the line trace:

See FirstPersonCharacter Blueprint for details.

I got some new facts, also:
It seems to have something to do with physics, especially auto weld seems to be a problem combined with line traces.

Replication of the problem:

  • Just look at the car and then at a wheel. As expected, they individually report a hit against their complex geometry. Without that flag the wheel would never report a hit as it is inside the simplified collision geometry of the car
  • Now turn on physics for the car blueprint
  • Repeat step 1. Now the wheels don’t report a hit anymore, it’s the same behavior as if we didn’t have checked ‘trace complex’

(I also tried to deactivate ‘auto weld’ for the wheels but that results in the car breaking apart or the whole model going completely crazy as the wheels try to glitch out the car.)

Many thanks and good luck.

Hi ,

I was able to get this to reproduce outside of your project with my own custom assets and have submitted the ticket UE-14520 for this issues.

Once there is any relevant information to pass along I will be sure to update here.

Thank you!

Thank you ,
looking forward to any update.

Hey ,

Just wanted to let you know this has been resolved with our internal build of 4.9.

Thank you for reporting the issue. :slight_smile:

Hey ,

that’s good to read, thanks for the update. Any ETA?

It’ll be released with 4.9 when that drops. As with all releases there is no firm date, but it’ll be on par with the amount of time for release between 4.7 and 4.8.

Hmm, ok. So I’ll wait for the update then. Thank you.