[4.7.5 Mac] Compiling UE4Game from source

Hi, I’m trying to compile 4.7.5 on mac from Github. The editor compiles without problems, but when I try to compile UE4Game - Mac I get the following errors:

Malformed block record in PCH file: '/Users/unstable/Documents/Unreal Projects/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Game/Development/Engine/EnginePrivate.h.gch'
Malformed block record in PCH file: '/Users/unstable/Documents/Unreal Projects/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Game/Development/Renderer/RendererPrivate.h.gch'
Malformed block record in PCH file: '/Users/unstable/Documents/Unreal Projects/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Game/Development/Core/CorePrivatePCH.h.gch'

I had no problems in building the same target in previous versions. Any suggestions?

Hello devel.bmad,

We are currently looking into this issue and we appreciate your patience while we test.

Just in case I need it in the future, would you mind providing me with your system specifications?


Of course. I’m using a MacBook Pro (Retina, 15-inch, Mid 2014) with OS X v10.10.2

Processor: 2,8 GHz Intel Core i7
Memory: 16 GB 1600 MHz DDR3
NVIDIA GeForce GT 750M 2048 MB

Please let me know if I can help you.

Hey again devel.bmad,

I attempted to compile the source code on the Mac we have here in house which is close to the exact model you are using as well. I was able to compile the ‘UE4 - Editor - Mac’ filepath without trouble, but like yourself, was unable to compile the ‘UE4 - Game - Mac’ filepath. Although I did not receive the same error message you did, I went ahead and entered a bug report for this issue.

We appreciate your patience while we work on finding a solution and issuing the fix in an upcoming release. If you have any other questions please do not hesitate to ask.


Ok thank you. Please keep me posted on the subject if there are any news.

Did you try a clean rebuild? Did you possibly upgrade Xcode recently?

I would suggest deleting this directory:

/Users/unstable/Documents/Unreal Projects/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Game/


Hi Josh, I completely deleted the source tree and downloaded it again from scratch from github, and now I can compile UE4Game without problems. The issue was probably related to upgrading from a previous version of the code. AndrewHurley in the post above wrote that he was able to reproduce the issue, it would be interesting to understand if he was upgrading too.

His error was something else (a failure to launch the executable). Building worked for him.

Basically, PCH files are not valid across clang versions. Or possibly it was an issue where it was compiled with old UBT with different settings than current UBT, but I would expect it to recompile the PCH files.

PCH files are strange black boxes that are hard to debug :slight_smile:


The error message I was getting was resolved by simply setting up a new clean build. After, I was able to compile UE4- Editor as well as UE4 - Game.