4.7-4.8 Dedicated Server not working

Hi. So ive been fighting this problem for weeks now without making any progress… Ive followed all guides on how to build a dedicated server, and its executable seems to work perfectly fine. However it is impossible to connect to it.
UE 4.7
Using Steamworks.

Game client build: development build (win64)

Dedicated Server build: development server build (win64)

Launching the dedicated server with -log commandline shows the server setting up a server and lissening to port 7777, nothing unexpected.

However, the server wont show up in the server browser, and trying to connect to it through console with command:
open ip.adress:7777 will do nothing and efter a while return “Connection Timeout”

When hosting a server from the game client however, everything works perfectly fine, servers show up in the browser, and users can connect without issues.

I thought there might be some router issue with the dedicated server, so I am now hosting it on an Microsoft Azure WM server, with all ports configured,… But still. Nothing. Again, running the game client on the server will work perfectly fine, but the dedicated server build does absolutely nothing…

Its really frustrating at this point…
Thanks for any help in advance.

I just tried hosting a game server with the command line argument instead (using 4.8.1 ):

UE4Editor.exe MyGame.uproject /Game/Maps/MyMap?listen -server -log

The log appares and shows no problems hosting the server, as usuall… It seems to use steam subsystem succesfully.
However still no server appears when trying to connect with the built client…

I dont understand why this is not working at all, I really need some help on this.

Before 4.8 it was possible to build a dedicated server executable, and trying to run this on my Azure server yeilded the same problems, the server and clients would never communicate, and the server would not show up in the list, not even when directly connecting to the IP adress of the server, the connection would just time out. ( the azure server had appropriately configured endpoints/ports)

The wiki page has now been updated and the server executable can now be built with 4.8+ versions of the engine, but I still cant get the dedicated server working. There might possibly be some problem with the azure servers endpoints, but if I can host a server with the game client on my local computer, should not also the dedicated server work the same?

Seems there might be some inherit problems with using the steam test dev app ID for dedicated servers, anyone who can confirm this?

This is my exact problem at the moment. Some help would be nice indeed!

It would appear, so far… that it does have something to do with steam… maybe? I’ve just got the server over to my Azure VM. Initial startups say that steam fails to initialize. I wonder if there is something else that needs to be done for the server build when using steam.

Well, I cant be of much help here. I have had the same problem for a long time and it seems that there might be some issues with the steam test dev app ID when trying to use dedicated servers. Haven’t had any real confirmation on this yet tho exept others having the same issues. Let me know if you figure anything out!