[4.7.3] Copy Pasting Blueprint Components, Can't Save Level

Hi Unreal folks,
Moved a project over from 4.6.1 to 4.7.3 recently, and uncovered what I can only imagine to be an error.
While making blueprint objects, if you copy and paste components in the object’s hierarchy (I tested with static meshes) to duplicate them, and then place the object in the scene you will receive an error, and the level will fail to save:

Can’t save …/…/…/…/…/…/███████████/██████████████████████/Builds/██████/███████████████████████████████/Content/Maps/TestIanWarehouse.umap: Graph is linked to private object(s) in an external package.

External Object(s):

Try to find the chain of references to that object (may take some time)?

To illustrate this, I made a single white-box shape made of 3 components, two quadrangular pyramids, and a cylinder, all static meshes. Each component was added to the object’s “Components” in the viewport through the “Add Component” button.

Then I duplicated the blueprint, removed one quadrangular pyramid, and then copy-pasted the other quadrangular pyramid component to replace the one I had removed. I colored it red, and both objects it in the scene.

When the one I had done the copy-paste method of adding in components was in the scene, the scene wouldn’t save. When it was removed, the scene saved.

The more you know.


Hello Chaosian,

I was unable to reproduce this issue on our end. I have a couple of questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

Hi Rudy,

I tried it in a blank project with starter content, and was able to reproduce it. Here were my steps:

  1. Open Minimal_Default.
  2. Delete chairs.
  3. Build lighting.
  4. In the content browser, create blueprint class, actor. Named it “Stable”.
  5. Opened up Stable.
  6. In the viewport, clicked the green button to add component. Added static mesh.
  7. Set StaticMesh to be Shape_Cube.
  8. Then, added another static mesh, Shape_Cube, positioned it at a Z of 110.
  9. Compiled, saved Closed Stable. Placed it into the scene.
  10. Saved scene. No problems.
  11. Duplicated Stable, “Stable2”. Placed Stable2 in the scene.
  12. Saved scene. No problems.
  13. Duplicated Stable again, “Unstable”.
  14. Opened Unstable, and deleted the top cube from the components list in the object’s viewport.
  15. Selected StaticMesh (the only remaining Shape_Cube in Unstable) in the components list.
  16. Pressed: Ctrl-C, Ctrl-V.
  17. Moved the duplicated StaticMesh back the Z position of 110, the location of the deleted cube.
  18. Compiled, saved, closed Unstable. Placed it into the scene.
  19. Saved scene. Error.

Can’t save …/…/…/…/…/…/Users/Ian/Documents/Unreal Projects/MyProject/Content/StarterContent
/Maps/Minimal_Default.umap: Graph is linked to private object(s) in an external package.
External Object(s):


Try to find the chain of references to that object (may take some time)?


Hello Chaosian,

First off I would like to say great job on the reproduction steps for this issue. Due to the accuracy of the steps listed I was able to quickly reproduce this issue and I have written up a report ( UE-12127) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

I had the same problem - this happened inside a blueprint also, without any nodes, with only these components:

  1. Root (Scene component);
  2. Floor (Static Mesh);
  3. Cube (Static Mesh);
  4. Cube copy 1 (Static Mesh);
  5. Cube copy 2 (Static Mesh);

After making the two copies by right-clicking the component window and copying / pasting from the original Cube, the same error started to appear when trying to save.

Deleted the 2 cube copies and the problem instantly disappeared. Every time i copy and paste from the original cube again the problem reappears.

I tried a creating a new blueprint and reproducing the steps but had no success. It seems like something went wrong with that specific blueprint that corrupted it somehow.

The only thing i did with the blueprint was adding, deleting and copying static mesh components to it (all of the mesh components were created inside, nothing from external blueprints). No modifications in the construction script nor the event graph were made.

I hope this gets solved soon, it is indeed a nasty bug and capable of hurting productivity / sanity very quick if it happens constantly.


Ok, just to complement, i successfully reproduced the problem with other blueprints (any new blueprint):

  1. Create empty blueprint;
  2. Add some meshes to it (does not matter the number of “original” meshes created);
  3. Copy and paste from one the meshes from step 2;
  4. Add the blueprint to the level;
  5. Try to save your project, the error should happen.

If you go back and delete the copies the problem stops.

Encountered the same problem yesterday!
So I can verify your post.

Hello ,

Thank you for your time and your additional information on this issue. I will be sure to bump the community interest in my report.

Make it a great day

Hi, this should be fixed by this commit. It will be included in the 4.8 binary release.