[4.7.3] Collision outcome is different in Launched Game

I have an issue since updating to 4.7.3.

Basically i have these enemies that spawn with a custom collision ‘enemy’. These are set to ignore another collision type ‘enemy projectile’. This works absolutely fine in the editor however launching the game; they instantly die due to the enemy projectile spawning on them and colliding with itself. I was able to launch without issue prior to the 4.7.3 update.

I’m stumped as to why it’s different from playing in the editor and in launched version.

Well, in case you are using BluePrint, try to debug inside the editor and see if everything works as expected.
however I’m still updating the engine right now.

Howdy Kelint,

Thank you for reporting this issue. I am going to need a bit more information before I begin investigating this issue. Would you be able to clarify if you are using a Binary build of UE4 or a Source build? Also, would you be able to replicate this issue on a blank template project? If so, Would you be able to provide repro steps so that I may be able to replicate this issue internally?

Any additional information would be greatly appreciated.

Thanks and have a great day!

I’m not sure; I’m kinda new to UE4,
After i updated i have been launching the game from the folder by rightclick>launch. But after i launched from the standalone game option from the play menu it seems to have fixed it, i can now also use the previous launch method without that particular problem.

However there is still a few inconsistent issues between playing in the editor and launched version. Right now the projectiles seem to fall downward when ‘projectile gravity’ is at 0. Again this works perfect in editor but not in launched game.

Howdy Kelint,

Thank you for the information. I have attempted a quick repro of this issue internally and have been unsuccessful so far. I loaded up a new first person template project and changed the projectile gravity to 0 but I was unable to see any change between Play in Editor vs. Launched.

What platform would you be launching onto? I also noticed that the Blueprint was not saving unless I selected save all. Would you be able to replicate this on a template project?


Hey Sean,

Thanks for trying, it seems the projectile doesn’t fall but its collision doesn’t register at a distance. I tried to replicate the bug on a twin stick shooter template but there was no difference between launched and editor. I have taken time to record what I’m experiencing since the 4.7.3 update. Hope this video helps.

I am launching on windows platform.

Since attempting a repro of this issue has been unsuccessful, Would you be able to share you project with me so that I may be able to replicate this issue internally? You can share your project privately with me via the forums. You can send me a private message via this page: https://forums.unrealengine.com/member.php?4890-Sean-Gribbin

I have attempted a couple of additional repro cases and have been unsuccessful as well.

Thanks and have a great day!

Sure, I’ve sent you a PM.

Thanks again.

Howdy Kelint,

Thank you for sharing the project via the forums. I was able to recreate this issue and have placed Jira Report UE-12446 into our bug database so that the issue may be release in a future release.

It seems that the projectile isn’t falling off but the lifespan is longer then it should be. I used the Show Collision console command and it display how long the enemy projectile should last compared to how long it does last once packaged.

I am not sure when the issue will be addressed or what build it may be resolved on but I will be sure to keep you updated as I know more.

Thanks and have a great day!

Ok Thanks! Does this also address the inconsistent collision on the enemies?

Sorry about that. I forgot to include that I have also written UE-12552 and placed that into our bug database. This bug is related to the collision issue between the players ship and the enemy.


Cool no problem, thanks for the help!

Hey Sean,

I’m near completion of my project and this bug is still breaking my packaged game 2 updates later. Is it still being looked into?

The projectiles collision is fine, but they are in fact falling.

I’ve made the projectiles a ridiculous size so i can see it clearly. I can get hit as long as the object is above the floor. But if you see the attatched image you can see the moment the projectiles are about to submerge below the floor in the launched version.

Edit: I have tried creating a new projectile blueprint and they don’t spawn at all in launch mode but works in editor. It’s really strange :frowning:

Hey Kelint,

I looked into the bug report that was submitted and this issue is still being investigated. Unfortunately, I am unable to provide a time table on when this issue may be resolved but I will be sure to update you as I know more.

Thanks for your patience.

Hey Kelint,

We have determined that this issue solely lies within your project. We have been unable to reproduce this error internally. Unfortunately, without being able to narrow down or isolate this bug or see any errors during packaging, it has been determined that this issue can not be fixed.

If you are able to reproduce this issue with a small template project and provide any repro steps, we can further investigate into what is occurring.

By looking into the logs, it could be an issue of collision being dependent on frame rate. How would you being setting up your Projectile collision? Would you be using physics simulation or using a ProjectileMovementComponent?

Thanks and have a great day!

Hey Sean,

I have found the cause of it. If you still have my project that i previously sent you can recreate the issue.

  1. In launch mode you should realize the bullets don’t hit at a distance and the enemies themselves have a collision during the first wave.

  2. In the blueprints folder there should be a ‘SurvivalGameMode’ or ‘MyGameMode’ blueprint. In the events graph of that there should be a bunch of collapsed graphs called Wave01, Wave02, etc. Delete all but Wave01 because the issue has to do with the class being referenced in any of these nodes within them.

3)In Wave 01 there should be another Collapsed Graph called Enemy01, There is a ‘Get All Actors of Class’ node. Select the actor class and clear it to None and delete the ‘length’ node.

  1. Launch again and you will see it has been fixed! However referencing that class again in the ‘Get All Actors of Class’ node will bring back the issue. So this can’t be a permanent solution but hopefully helps narrow down the bug.


Glad to hear that you were able to narrow down the cause of the collision issue. I will be sure to revisit this issue and use the information that you have provided to repro this issue. I will let you know how the testing goes.


Any progress on this? I kind of had to remove that get all actors of class node to bypass this issue, but can’t say it’s been solved. Sorry.

Howdy Kelint,

Sorry about the lack of response. I have just tested this issue in the latest release (4.8 preview 3) and have not been able to reproduce this issue. Would you be able to open a copy of your project in this build and test this out on your end? Be sure to keep the 4.7 build as well because the preview builds are not intended to be developed on. They can be unstable at times.

Be sure to let me know how testing goes so that I may be able to test this further as needed.