[4.7.3] Can't do animation in the Matinee Editor; Don't know what to do about it

I make a simple test matinee animation consisting of moving a block from side to side in one direction, for me to get familiar with the Matinee Editor. As I went on, I noticed that the static mesh wasn’t doing anything, such as moving across the floor.

I realized the Matinee Editor, even though it correctly put keys in, wasn’t able to move the static mesh around.

The static mesh is already set to Movable. And it has been added to the “Block” matinee group via “Add Selected Actor to Group” in the Matinee Editor.

I even set the level blueprint up so that it plays the animation upon Event Begin Play, yet the actor isn’t moving.

I really don’t want to say this is a bug, but being unfamiliar with the actual results and not expecting them to be like this, I really don’t have any other understanding other than to say that this is a bug in the Unreal Engine 4.7.3. What should I do?

Thanks in advance.


Binary, from Launcher



Hi asperatology,

I tried what you are trying and it always seems to give me the proper result on my side.
Here are the steps I use so maybe you can reproduce them or validate if you’re not missing one

Create a new blank Blueprint project using 4.7.3
Take a Cube in Basic / cube and place it in the viewport
Click Matinee / Add new Matinee in the main toolbar
Select the cube in the viewport
In Matinee, right click, add empty group
In Matinee, right click on your new group and Add a movement track
In Matinee, move the timeline and add a new key
In the viewport, move your cube (you should see the yellow line appear)

And that’s it, at that point If i save and start in in my level BP everything’s fine or If I click the loop in the matinee editor, both ways show me my cube moving

Hope this helps

Let me know what are your results


  • Marc

I decided to redo this by using a static mesh created from scratch, and the result is affirmative. I was able to move around and animate the movement track.

However, I now realized it does not work with C++ objects with an Actor as root component and UStaticMeshComponent as child attached to root component. The matinee editor cannot animate C++ classes such as that.

Is that a bug?

I ran into this problem as well. My object is a blueprint, not C++ object, but it has a StaticMeshComponent child. I got the object moving via matinee by unchecking “simulate physics” in the StaticMeshComponent.