[4.7.2] OS X Packaging to Android: NDK Fails

Hello guys,

I have an issue with building Android package. NDK fails with “armeabi-v7a” args. I can’t understand what wrong with it?

My device – Nexus 4, Android 5.0.1

Components version: android-ndk-r10c, apache-ant-1.9.4, jdk 1.7, android sdk 24.0.2. OS X 10.9.5 Mavericks.

See my log ([text version][1]):

http://dl2.joxi.net/drive/0004/1339/312635/150305/c77edb19a1.jpg

I think the key may be here: Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo.

Make sure that you’ve opened Xcode & agreed to let it install all its extras.

Running from terminal with ‘sudo’ doesn’t helps.

I tried this:

sudo open /Applications/Epic\ Games\ Launcher.app
sudo open /Volumes/Data Mac/Projects/MyProject.uproject

Might be totally unrelated since you are getting privilege error deploying while i’m building from source anyhow…
from mine observation along with long useless hours of configuration I found out that for mine source version, the highest supported version of NDK is android-ndk-r10c.

So, you’ll better to try to use it, instead of android-ndk-r10d

Unfortunately, it doesn’t help too…

Exception in UnrealBuildTool: ERROR: /Volumes/Data Mac/android-ndk-r10c/ndk-build failed with args APP_ABI="armeabi-v7a " NDK_DEBUG=1

Also tried 9c and it’s doesn’t help too. Why EpicGames didn’t provide OS X guide yet, if there so many dependencies?

Open Xcode.app & allow it to show you the required license agreement dialog & install its necessary internal additions that need to be installed per-user account. None of UE’s build system will work properly until you do.

Can you add the log from a new build then? I need to know if that message is still there & if it isn’t what may now be going wrong instead.

I already did it. Doesn’t help.

It’s the same. Anyway I will provide you new log later today, because now I’m out of office.

New log - LogPlayLevel: ====07.03.2015 1:36:38====PREPARING TO MAKE APK=================== - Pastebin.com

So, I tried to do that on other mac with the following configuration: 10.10 Yosemite, UE 1.7.2, ant 1.9.4, jdk 7, ndk 10c, sdk 24 and build was successful.

On my mac installed 10.9 Maverick. But I don’t think that it is the reason.

The problem was in path to the ndk - path must be without spaces. Thats it :slight_smile:

download and instal sdk and ndk and jdk in this video : Unreal Engine Setup Android SDK and JDK and NDK - YouTube