4.7.2 Cooking failed due to CF3 modules

Hi,

When launching the cooking process for my project I have this error
UnrealBuildTool: Exception thrown while processing dependent modules of WebBrowser
UnrealBuildTool: Exception thrown while processing dependent modules of CEF3Utils
UnrealBuildTool: ERROR: Couldn’t find module rules file for module ‘CEF3’.

My project has a dependcy on the Webbrowser module but it seems that some file are missing in the 4.7.2 to allow cooking.

Could you please fix this?

Hey Elvince,

In order to assist you further, would you please provide me with the output logs from the Editor? You can obtain these by either going to where you saved your project: \Unreal Projects\MyProject9\Saved\Logs and uploading the .txt file or by going into the Editor, having the process fail and then go to: Windows > Developer Tools > Output Logs and then you can select all of the logs and paste them into Notepad ++ and upload the file to your next reply.

Please also provide how exactly you’re cooking your build, and whether or not you’re using the Editor or UnrealFrontend.

Looking forward to assisting you further, thanks!

Here is the log file for the issue:
link text

I’m cooking from the editor, using File>PackageProject>Windows>Win64

Hey Elvince,

How did you obtain the Unreal Engine? Was it through the Launcher or through GitHub? If it was through GitHub, could you tell me the order in which you built the Editor? Did you run Setup or GenerateProjectFiles first?

Thank you!

I get unrealengine via the Launcher.

Elvince,

Have you been able to successfully ‘Launch On’ with your project? Also, have you been able to get your project to successfully package using UnrealFrontend? If you haven’t tried yet, would you please do so at this time and provide me with any error logs you may receive?

Were there any options that you may have changed within the Editor, especially for packaging?

If you haven’t been able to package or launch on from the Editor, please open up the Launcher and go into ‘Library’. Once there, please select the drop-down option and select ‘verify’. Once the Editor has been ‘verified’, try to package your project once again.

Thank you!

Hi,

LaunchOn give the same result.
I didn’t try using UnrealFrontEnd

As far as I remember I didn’t change any option for packaging. I just click on it to try :smiley: I just uncheck the environment that I’m not targetting (like Android, Ios …)

Another information that may help is that I’m not able to compile my project in Visual Studio for the “Development” configuration with exactly the error I provided.
On the other end, “Development Editor” and “Debug Editor” configurations are building fine.

So the error seems to be linked to non “Editor build”.

Thanks,

Could you please confirm that on your side you have been able to build a project that was relying on WebBrowserModule in “non editor” configuration with the Editor provided by the launcher?
This will also help to track down the issue (and provide you information) if this is related to my project setup.

Hey Elvince,

I’ve gotten in contact with the Developers regarding this issue and there is going to be a plug-in implemented when 4.8 becomes available. An updated was released on this AnswerHub post earlier this morning: Ue4.6 Experimental: Web Browser UI Widget? - Platform & Builds - Unreal Engine Forums

Thank you :slight_smile:

I’m sorry but the thread that you linked is another topic. The thread is about getting the WebBrowser in an UMG Widget so people using UMG can use properly.

I’m using Slate and creating the WebBrowser directly.
So the 4.8 UMG Widget won’t fix my issue.

Could you please ask again the developper with those information and saying that I’m using it via Slate directly? I think it’s missing a file somewhere in the Launcher binaries but I’m not an expert in the packaging part so I can’t track it down.

Thanks,

Hi,
FYI, if I remove the reference to the WebBrowser module everything build without any errors.

thanks for your feedback.

Hey Elvince,

I’m glad that you were able to fix this over the weekend. And we appreciate you posting your resolution, in case anyone else runs into the same issue that you experienced.

If you need any additional help, please let us know. Have a wonderful day!

Sorry if my comment add some confusion, but the issue is clearly not fixed.

I just add that my code can be built without any issue if I remove the dependency on the WebBrowser module but I need it.

As of today, you can’t build a project that is dependant on WebBrowser module via the Launcher UE4 version. This is to be fixed unless there is a specific parameter that I miss and I will be glad to get it.

Could you please follow up on this with the developpers?
It’s easy to reproduce this as you just need to create a project, reference the WebBrowsermodule, add a Webbrowser variable in your .h. and try to build in a “noneditor” configuration.

thanks,

Hi there, I’m afraid we still don’t support the use of the WebBrowser in packaged games from the launcher as yet. Because of the way that the launcher build uses a single UE4Game.exe, there wasn’t an easy way to make sure that the necessary components for the web browser could be optionally included. There was a plan to add a dummy plugin that would merely add a reference to the web browser module and ensure that it was built but there were some problems with it so it was pulled from the 4.7 build.

You could perhaps try adding WebBrowser to the list of OutExtraModuleNames in UE4Game.Target.cs, with the understanding that this would force the web browser to be included in every game made by the launcher build. Or you could try adding a dummy plugin like we planned, which would add a public dependency to the WebBrowser module and force it to be used when active.

That said, I’m still a little confused about the error you’re getting. It seems to suggest that the third party CEF3 module doesn’t exist but if you’ve been able to use the web browser in non packaged builds then it must be there. You could double check that Engine\Source\ThirdParty\CEF3\CEF3.build.cs exists as I assume this is what it’s looking for (unless something else is forcing it to not be used and it’s acting as if it doesn’t exist).

Thanks for the update.

l will try the OutExtraModuleNames as a workaround. I will keep you updated on this.

Otherwise, if I build the engine from github do I need to do anything specific to get the WebBrowser included? Or once built, everything will work as intended?

For my error, this is the output from UBT. I checked that the file exists in this directory. I bet there is a side effect somewhere that raised a misleading error message.
It could be good to track this on your side if there is a side effect error in UBT. It might be good to fix it for the future.

Thanks,

I’m not familiar enough with the git process to say for sure how it will work really. I think there are unfortunately extra steps needed to package the web browser in any project, internally other projects have had to add .target.cs file changes as well but these can be made on a case by case basis as they will have their own gamename.target.cs file.