Download

[4.7.1] Building for Linux from Win64 is just redirecting me to the documentation

As there’s no Linux Development section I’m posting this here. Running UE 4.7.1 on Win10 64-bit Preview 9926. Would rather be running on Linux natively, but MESA/Radeon/drivers, sigh.

Clicking on File->Package Project->Linux is taking me to the UE4 Documentation Index. I’m guessing it’s trying to find specific documentation for Linux, but failing (if so, at least it isn’t 404-ing).

Am I missing something? I would imagine the answer is “Yes”, just that I don’t know what. Anyone have any ideas?

Thanks!

You are indeed missing something … you need a Linux Toolchain to compile for Linux on Windows.

Compiling For Linux

If you wanted to build natively on Linux, you would go here: Building On Linux

Which I guess is where the documentation was trying to go, then. Thank you, good sir! Shall get that set up and running.

Built UE4 natively on Linux, it’s just that I can’t run it (due to driver issues and general hardware/driver interactions).

Also, the Wiki page for Compiling for Linux implies that if you don’t have the cross-compiler toolchain installed the Linux options shouldn’t be available from Package Project. This was not the case.

Did you build from the Source Code (i.e. GitHub) … because if you did I think the option is there but it won’t work because the Toolchain is not there. I got caught out by this when I first tried to compile for Linux on Windows. 8-}

Nope, not self-compiled, just downloaded the installer and ran the Launcher.

Hmmmm … weird. Let us know how the build goes.

Toolchain installed (to C:\Develop\UnrealEngine4\CrossToolchain). Can’t find the GenerateProjectFiles.bat needed to regenerate the project files, though. Attempting File->Package Project->Linux produces the same results as before.

I have VS2013 Community installed.

Dunno if these lines from the log would be relevant, but anyway - these seem to happen if I do File->Package Project->Linux:

Same problem here. Downloaded toolchain, set variable LINUX_Root, regenerated project files, “Linux” not available (only Win32 and Win64 as before).

Same thing , I did try the powershell script as well.

Same problems

I just downloaded the latest engine source files from github, I followed the instructions for the toolchain from here and when I run GenerateProjectFiles.bat I get this error:

707a87944e4ceb58afca9fbfa21180d9e8d36662.jpeg