[4.6 UMG Critical Bug] Images do not appear in Standalone, only in PIE, broken from 4.5 where they worked

Dear Friends at Epic,

In 4.5 I made a bunch of UMG systems

In 4.6 they are all broken in standalone / running game from commandline only.

In editor they still look normal.

But in standalone, all the background images disappear!

#Repro Project, 8mb download

I have created a repro project for you, download is 8.2 MB or so.

It’s 4.6 release, please download and run in PIE and standalone and notice the difference.


Please understand you will only see my repro if you actually run the game in Standalone, PIE works normally.

#Github Fix please

I need standalone to work, as soon as possible!

Can you please tell me the github fix for this once it is made?




It seems that the disappearing issue in Standalone only affects Images that have Brushes / Materials / Textures!

Pure color images still show up in standalone.

I will have to use simple color backgrounds for my UMG menus until this issue is addressed properly,

so please do give it a high priority!

Hello ,

I took a look at your level and it acted as you said that it would. However, I opened up a clean project and could not reproduce your issue. After that I went back to your project and created a new widget and again was unable to reproduce this issue in the project that you provided. While the original setup does cause the error, I am unable to create a reliable test case with the current information given.

Quick questions:

  1. Can you reproduce this in a clean project?
  2. If you are able to reproduce this, can you provide accurate reproduction steps for this issue?

I did find that this works with your current setup and could be a possible workaround depending on the complexity of your widgets.


  1. I Duplicated the Widget that you provided
  2. In the Original widget I deleted the scrollbox and textblock
  3. I changed the images Zorder to something higher than the scrollbox’s (I used 3)
  4. I then navigated to the duplicated widget and removed the image
  5. In the level blueprint I made sure to add the duplicated widget after the original (The original was the one with the image and the duplication was the one with the scrollbox and textblock) This causes the widgets to be add to the viewport in the order of Image > Scrollbox and textblock

I hope this helps until another less hackish solution can be found.

Make it a great day

#Full Repro Steps

First of all it is very nice to hear from you directly Rudy! I am loving UMG! I even made my own in-game file system using UMG!

Here’s complete repro steps, I just did it again, and recorded each step as I did it

  1. 4.6.0 release, new project, third person, no starter content
  2. new widget BP, called new widget BP
  3. make image first, leave z order at 0
  4. make a new material, color parameter called Color
  5. Has to be a translucent material, using only emissive channel
  6. Opacity comes from color alpha
  7. make material instance with color set to some values
  8. Back in widget, set the image to use the material instance
  9. In widget, make new scrollbox, z order 1
  10. make text block inside of scroll box, set to some text
  11. move the scroll box over top of the image
  12. in level BP add widget to viewport on begin play
  13. Play in PIE, everything is normal, background shows up
  14. Play in standalone, background does not show up, bug has been repro’ed

Again I did all of this as I wrote it to you, and here is the result in standalone:

#I Had Already Fiddled With Z Order

I called the project UMG_ZOrderBug because I did also notice I could sometimes get the background to appear if I changed the z orders around

I made the background 1 and the scroll box 2, and then it showed up, briefly, but then when I added new widgets or changed z order of other widgets, it would revert again, so that was not a reliable solution

Please note all reliable testing has to be done in Standalone or commandline version of game.

#Very Worth Noting

Please note I do not experience this bug in standalone with UMG Images that are based on Texture2D brush content, it seems to be only materials.

#Thank You Rudy

Thank you for Slate and UMG Rudy!


Hello ,

Thank you for the detailed steps for the reproduction of this issue. I was able to reproduce this issue 100% of the time on 4.6. After that I was able to test this issue elsewhere and found that the problem has been fixed on an internal build and will be available in a later release of the engine. Once again thank you for your time and information.

UPDATE: After further testing I was able to reproduce this internally as well.

Make it a great day

“After that I was able to test this issue elsewhere and found that the problem has been fixed on an internal build and will be available in a later release of the engine”

Ooh great to hear!

Thanks Rudy!

Hi Rudy,

I just tested this on 4.7 and it won’t be in there. Can you provide the link for the Github fix for it? It will be painful to wait another version or so to use standalone. Thanks, I appreciate it!

Hello ,

I just tested this again in 4.7 and it appears to be working on my end. Could you supply me with the steps that you took in order to achieve this issue?

Sure, I just did a fresh Unreal 4.7 preview 4 project. Blank with Starter Content.

  1. Created basic game mode and player controller to create my umg widget on event play and add to viewport.

  2. Created a material, Unlit, Translucent, checked “Used with UI” settings

  3. Connected a plain Green color to the Emmisssive Color, and put “0.5” for a single constant connected to Opacity

  4. Created a UMG Widget with a Canvas Panel.

  5. Added a simple Image Control, attached the material, and increased the size to 700x700.

Compiled and ran the Game in PIE & New Window just fine. The image comes in halfway transparent as expected.

If I then run “Standalone”, the image is not there. Its like the opacity is 0.

I tried to keep this repro as simple as possible. If you need more info or the project let me know.

Thanks Rudy!

Hello ,

I am using the the 4th preview of 4.7. Is this the same version as the one you are using to create this issue? Would you please attach your project so that I might take a look at it?

Sure, I can do that, it is preview 4 of 4.7

I have attached the zip file. Thanks!
link text

I just figured out a work around on this issue, but I think this is still a legitimate bug to report =)

In my project,

  1. I right clicked my topmost control connected to the “Root” which in my case was an “Overlay”.

  2. I click “Wrap with…” and selected a border control.

  3. I set the border as “Self Hit Invisible” & set the alpha to “0.0”

This lets all the children controls draw correctly in standalone.

Let me know what you find out on the project I sent on your end. Thanks Rudy!!

Hello ,

I would like first to apologize. It appears I was wrong when I said that it was fixed internally. I must have missed a step in the reproduction process or have done something differently. I tried again today and was able to reproduce this issue across multiple builds. Thank you for bringing this to my attention as well as for you information and time. I will update the known issue with new information.

Rudy thanks!

No need to apologize. I’m just glad that I can help make the engine even better =).

Have a great day! =)