[4.6 Preview] UMG Colour & Opacity no longer accepts Linear Colour

I’m not 100% sure if this is a bug or not, but I have a system within UMG that changes the colour of the UI text based on gameplay.

If you have >50 bananas the text is green.
If you have <50 it is white.
If you have 0 it is red.

This is set using the Bind Colour and Opacity in UMG. This is fed a linear colour variable which is read from the player blueprint.

In 4.6, Colour and Opacity bindings only accept Slate Colour instead of Linear Colour, and I am unable to set the colour in blueprints with Slate Colour (It is pink no matter what.)

Hello Kenomica,

I have a few questions for you that will help me narrow down the issue that you are experiencing.

Quick questions:

  1. Can you reproduce this in a clean project?
  2. If it is possible to reproduce in a clean project, could you provide accurate reproduction steps?
  3. Could you provide a screen shot of the blueprints that are involved in the issue?

No problem!

I’ve found that in order to get the correct colour, you now need to:

  • Change all variables to “Slate Colour” instead of “Linear Colour”

  • Change all “Output” bindings on opacity and Colour to “Slate Colour” instead of “Linear Colour”

  • If the variable & output are both “Linear Colour” you will receive a “Signatures Don’t Match” error.

  • You cannot set the colour as normal in the new variables, you must drag off the pin of “Slate Colour” and -

  • Select “Make Slate Colour” - Choose the colour.

In a new project, this is still necessary but by default, binding colour and opacity will give a Slate Colour. Old projects need a LOT of reworking to get the colours working as they did in 4.5.1

Hello Kenomica,

I was able to reproduce the issue. I have written a report ( UE-5645) and I have sent it to the developers for further consideration. Thank you for all of your information and time. I will provide updates with any pertinent information as it becomes available.

Make it a great day

just updated to 4.6 and this issue is still there.

Hello Kenomica,

I went ahead and double checked for you. There are still no updates on this issue as of yet. The development team been working hard on finalizing the 4.6 build for the release. I will be sure to update you when there have been any changes to the status of the report that I wrote up.

Much appreciated. Thank you.

As of 4.10 this bug is still there. If you use the above function, the text goes black, Slate color or not. When you set some degree of transparency, the color you selects comes out to some degree, but if Alpha value is 1, the color is firmly black.

Is there any update on this? This has been over a year now

Hello ,

I went ahead and double checked for you. This issues status has not yet been updated to fixed as of yet. However, I will bump up the community interest on this issue for you. Thank you for your interest in this issue.

I’ve come across this bug in 4.13, has it still not been fixed or could I be having a different issue?

Hello Umaya,

I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-5645)

Make it a great day

An alternate solution for that is when exposing the slate color variable in blueprint, split the struck pin and hook it to the linear color variable.