[4.6 Preview] Can't disable Root Motion

when I turn on “Root Motion from Everything” in AnimBlueprint and turn off “Enable Root Motion” in AnimSequence, Root Motion is still enabled and for animations which are in-place and don’t have Root Motion, my character stays in place.

Please help me.

For example: example assets from Third Person Template. I want to Enable Root Motion for Jump but not for locomotion.

Hi ,

Can you please be more specific and descriptive about what you are trying to achieve. For instance, which specific animations are you having problems with. What do you want the specific animation to accomplish?

Also, can you create and post a test-asset which can reproduce the issue without any concerns about sharing with the general public as we do not have a way for you to send them to us directly. If you can post a test asset, this would help immensely.


No. I want to use “Root Motion from Everything” but block Root Motion for locomotion animations.

Thank you for clarifying. If I understand you correctly, then you would want to select “Root Motion from Montages Only” in your graph and enable root motion in your animation.

To address your original question “…Root Motion is still enabled and for animations which are in-place and don’t have Root Motion, my character stays in place:” This is expected behavior as shown here:

Once Root Motion is applied you can apply translation and rotation as described in the rest of this article:

Do you know about Root Motion changes in 4.6? I’m not using Montages for Root Motion but AnimSequences…

Hi kodmistz,

Sorry if I’m not addressing your specific issue. Please describe in as much detail as possible, step by step what you are trying to achieve and why you are selecting “Root Motion from Everything” but want to turn off “Enable Root Motion” in the AnimSequence.

If I cannot answer your question I will consult with a developer or have a developer take a look to determine whether this can be achieved or if there is currently a problem with the editor itself. (Again to get to this step will require as much information in as much detail as possible.)

Please be patient, as a developer will not be available until after the holiday.

  1. Run “Blueprint Third Person Template”.
  2. Go to Characters/HeroTPP_AnimBlueprint.
  3. Edit Defaults → Check Root Motion Mode: “Root Motion from Everything”.
  4. Click “Play”
  5. Character can’t moving though Run and Walk animations have “Enable Root Motion” in Persona unchecked.

I was able to reproduce the issue following the steps you have provided and have filed a bug report [UE-6109]. If this turns out not to be a bug, the solution for using this feature will be posted here. Likewise, if it is indeed a bug, an update will be posted here once it has been addressed.

Thank you for your feedback.

Hi kodmistz,

I was able to reproduce your issue and filed the following report: JIRA [UE-6109]. The issue has been fixed for a future release of the engine.

Thank you for your feedback!

I also detected other problem…Now when I try to change “Root Motion Mode” and next click COMPILE button it reverts to old value…

  1. Open AnimBlueprint.
  2. Edit Defaults → Check any other option than currently selected.
  3. Click “Compile”

At the top of the “Anim Blueprint Editor” tab it says “Edit Preview” and “Edit Defaults…” -You have to select “Edit Defaults” so it is highlighted in orange in order for it to save your changes when you compile/save.

Ohhh, indeed :slight_smile: Sorry for that… I’m today very distracted…