4.6 HTML5 Won't Render

Hello. First, I apologize if this is in the wrong place or I’m missing something obvious, as I’m new to Unreal.

I’ve been investigating the HTML5 exporting capabilities of Unreal the past few days. Unfortunately, I’ve been unlucky so far. I’ve overcome a few hurdles but now I’m stuck with the builds launching but not rendering (though sound is occurring and I can tell the project is running correctly). I’ve followed the getting started guide and the answer for 4.5 that I’ve seen linked in other questions and forum posts. Here’s the exact steps I’ve done and reproduced to get to this state:

  1. Download the source code from Github.
  2. Install Emscripten 1.25.0.
  3. Run Setup.bat.
  4. Run GenerateProjectFiles.bat
  5. Opened the project in Visual Studio 2013 Community, as linked to in the Readme.
  6. Compiled the solution under Development Editor - Win64.
  7. Compiled the UnrealFrontEnd.
  8. Launch the Frontend, setting and launching a custom launch profile as described in the second link.
  9. Run the editor through Visual Studio.
  10. Create a new project: First Person Shooter Blueprint (I’ve tried others as well, see below)
  11. Launch from the editor into Firefox Nightly (64 bit).

The project launches fine and the browser opens up. It goes through downloading, then running, and then the project begins to play except that the canvas is blank. I’ve tried launching the project through the editor and the frontend to the same result. I can hear sounds and can tell the project is running correctly but just cannot see anything. I’ve tried the First Person Shooter Blueprint, Side Scroller Blueprint, TappyChicken Sample, and the First Person Shooter Sample (this one got stuck on downloading, which I assumed it was a combination of being too large and the multiplayer server aspect). I’ve tried both development and shipping builds as well. I get no errors, but the log in Firefox (not the console, the Unreal log) will regularly spit out the following:

[2014.12.18-16.45.26:433][165]LogRenderer:Warning: Reallocating scene render targets to support 1336x840.


[2014.12.18-16.45.26:457][166]LogRenderer:Warning: Reallocating scene render targets to support 1600x904.

These two messages (with different numbers before LogRenderer) will constantly spit out if I try to interact with the canvas in any way. I’ve also tried Chrome 64-bit, but the tab just fails on Downloading with a generic “Oh Snap” and the Output Log on Unreal has the following error, which I could not find elsewhere:

LogPlayLevel:Display: Program.Main: ERROR: Exception in AutomationScripts.Automation: Client exited with error code: 7012

Am I missing a step somewhere? I’m using Windows 7 SP1. Any help would be appreciated, thanks.

You’ve just perfectly described what I am also experiencing.

Ok, so I had this exact same problem. I tried running the exact same packaged HTML5 project on a different computer and it worked perfectly, looks like it was something specific to that machine, perhaps the old graphics card it has?

The machine I’m on is using a NVIDIA 750M, so I don’t think it’s that. It also renders and works just fine using Unreal 4.5 (which we were forced to swap to for my current project). It just seems to be 4.6 that’s giving me difficulties.


Have you tried other any other browsers or other OS? Say Nightly on Mac? As a test in Nightly can you try going to the address “about:config”. Search for webgl and enable the setting “webgl.disable-angle”?

Hi terryrgs,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.