4.6 Delegate error on open even after fix. Cannot progress forward

Before I go into details let me provide all of the necessary information for you to be able to reproduce the issue.

Blueprint error log after open:

Screenshot of blueprint after open:

Full source/content for project (4.6 c++ code)

So, every time I open the project I am greeted with the error messages provided in the log above. When I open up the offending blueprint it shows the error as reported (see screenshot link above). All I have to do is click compile and the error goes away and I am able to run in PIE. The delegate is fired off at the appropriate time and things seem to work properly.

My problem, however is when I close/reopen the project. I have to go through the same steps. Now, normally I would not create a ticket for such an issue but there IS a problem when I deploy this for iOS. When it creates the package for iOS it must have those errors present. I know this because I have messages to tell me when the delegates are fired and they are NOT firing when I run it on my iPAD. I’ve had the project running since 4.2->4.3->4.4->4.5 and it was recently upgraded to 4.6. Everything is set to run as a DebugGame so I know I should be receiving the log messages. Also, I know because the game code is being ignored as a response to the delegate.

I’ve tried creating a brand new delegate but I receive the same issue upon opening (with the new delegate name). There is something inherently wrong with our blueprints or object hierarchy that needs to be addressed. We cannot move forward until it is resolved. Please provide a possible workaround in the meantime and let me know how I can better move this ticket along.

Thank you,

Howdy jeffvoigt,

Thank you for reporting this issue. I have been able to replicate what you have been seeing thanks to the project that you have shared on this post. I have entered JIRA report UE-6635 into our database so that the issue may be fixed in a future release.

Thanks and have a great day!

Hi Sean, just checking whether 4.7 will carry the fix for this issue. Because of this bug I too am having to recompile a blueprint using event dispatchers every time I start the engine so eager to see it fixed!

Howdy VSZ,

The current status of that report is ‘to do’. I am unsure as to when the exact point that this will be fixed is but i will be sure to keep you posted.

Thanks for your patience and have a great day!