[4.6.1] Spawning a child actor from it's parent; compile failure

Hi peeps,

Using 4.6.1, I’ve discovered I can’t seem to use “Spawn Actor from Class” to spawn an actor that is a child of the blueprint I am in. If I do, the blueprint never compiles, though there are no errors or warnings in the compile log.

For example, if I have two blueprints, BP_A descended from Actor, and BP_A_Child descended from BP_A, if inside of BP_A I try to spawn an instance of BP_A_Child, the blueprint won’t compile. I tried this in a 2D sidescroller sandbox project I made, and it does seem to be a bug. Has anyone seen this and/or have a workaround?

I’ve tried a little workaround which involves having another blueprint control the spawning of the child, but I think I’ve hit the same problem because BP_A calls into this intermediary, and this intermediary spawns BP_A_Child. While everything compiles, it breaks my project (editor crashes and unable to reload the project without rolling back the blueprints).


Edit: After trying to replicate my crash using the intermediary in a Sandbox project, I’ve not been able to do so as yet. So the crash may be unrelated to the spawning of descended blueprint instances from a parent blueprint instance.

Cheers. Just a note for anyone else having this issue, what I’ve done is add that intermediary, and when I close my project, just unwire the functions that spawn the child classes. This way the project reopens fine, and you can compile and work on it. Unfortunately I just can’t get a barebones repro of the crash on startup, which makes me think it’s not just a knock on effect of this compile failure.

Hi ,

Thank you for your report! I was able to reproduce this on my end and have entered a bug report, UE-6932 to be assessed by the development staff.

I have the same problem, and the intermediary solution works for me, so that crash you are having is likely unrelated as you suggested.