Download

4.6.1 Hotfix is Live!

Have a look at the fixes available with 4.6.1!

4.6.1. Fixes

  • ContentExamples Media map movie no longer renders black.
  • ContentExamples Media map no longer shows the UDK splash screen.
  • ContentExamples Media map is no longer missing source video.
  • XBox One now boots from Visual Studio correctly.
  • Fixed an error that caused material If nodes to break.
  • Fixed a bug that was causing new and converted non-ascii text projects to crash.
  • Corrected a bug that prevented composite decorators from being opened in Behavior Trees.
  • Event Nodes can now be called for Event Dispatchers.
  • Fixed an error that prevented the creation of new events in the AnimBP Eventgraph for new Anim Notifies.
  • Corrected Static Lighting on InstancedStaticMeshes.
  • Corrected the adb path and device serial number for Android packaged install batch files
  • Fixed an error that caused crashes on Android when Touch events were called too early.
  • Fixed a bug in pathfinding when default querying extent was not large enough on the Z axis.
  • InstancedStaticMesh now renders correctly on mobile devices.
  • Corrected a bug with animation retargeting adversely affecting looping animations.

Adam, can we expect Fixes to Cascade Color modules to come in the next hotfix? It’s a real bummer having to wait for 4.7 otherwise!

Hey TheJamsh,

At this moment we do not have plans for another 4.6 hotfix, so the “Color Information Clamped to a Max of 1 in Cascade Color Modules” issue you mention is slated for the fix to be in 4.7. Although if you are using the source code for GitHub, I could find the commit to the master branch which contains the fix. Let me know.

If you weren’t aware, there is a workaround listed for the issue: “You can graph it and select the point you want to change and then set value to any number, but it will be clamped back to 1 if you adjust in Details Panel.” Not ideal I know. Sorry for the troubles.

I just use the color picker!

The color picker values are not weirdly clamped and you can enter the values directly like you would normally

**
Github Fix**

For anyone with a Github engine you can apply the fix yourself here:
https://github.com/EpicGames/UnrealEngine/commit/1e085ee2ae42dff7a83e39722346962d7b2d4d34


♥

Rama

Is there any news on the demo recording/playback bug in Shooter Game?

Does this fix all the random crashing people are getting?

Not only do I second this question, I would also like to add:

If I accidentally put a loop in my game, I understand the detection and reporting of that loop is important. It keeps me from crashing my game, however, for the love of the gods, please do not replace that with infinite popups telling me that I have a loop. It is obvious that Unreal detected it, so please terminate the process.

Thanks for the hard work guys and gals!

When will the SqliteSupport fix be included? In 4.7?

I agree with this too. +1

Thank you Epic for this small update

Yeah I have issues with while loops in BP, there are instances when Ive wanted to use them and simply cant because they hit the iteration limit in a split second even when I try to put a delay in there. There are instances when you want a loop to runaway for awhile only to come back when the condition has been met, its just a shame that the iteration limit is the same on both for and while, if I raise it for while then I could potentially put myself in trouble with for loops I dont want to run for so long.

I actually suggested a detection in the closed Beta testing because I had put while/for loops in construction script and it was causing my BP to crash out when I opened it, making it an irreversible error. I think I did find a way to stop the construction script of a Blueprint through its properties but that option seems to have been removed in the right click menu update for the Content Browser :cool:

You could use a Gate-Loop instead, or write your own “while loop with delay” (Double Click the loop node. That works great btw).

Different loop options are great, but that popup is annoying at a level words can’t explain.

Ah okay, thanks Stephen! Wasn’t aware of the graph workaround!

Well, the author of his car AI project told me this fix would fix my issue about the event node, but it didnt:

https://answers.unrealengine.com/questions/147779/after-46-conversion-from-45-bp-error-again-and-aga.html

Same issue like with 4.6.0 : You click compile, it works, you save, close project, open again, its broken again.

It’s a lot easier to just use the Color picker :slight_smile:

That’s the solution I came up with that has been working great for me :slight_smile:

**
Github Fix**

For anyone with a Github engine you can apply the fix yourself here:
https://github.com/EpicGames/UnrealEngine/commit/1e085ee2ae42dff7a83e39722346962d7b2d4d34

Rama

My advice was only meant to solve the “Loop till condition changed”-algorithm, which simply will not work with a while loop. The while loop ignores a delay/timeline in the loop body and iterates simply so fast, that you reach the infinite loop threshold nearly instantly.

Hi Shirk, it will fix some crashes, but I will need more details about the crashes that you are experiencing in order to investigate that further. Can you please submit a bug report to answers.unrealengine.com so that I may assign a technician to look into it further. Please fill out your report with your crash callstack and as many details as possible to help our staff.

It did not get the crashes I am getting, see https://answers.unrealengine.com/questions/145650/engine-46-and-451-crash-like-mad-on-mac-os-10101.html
That is on Mac OSX 10.10.1. BTW when I run on windows using Parallels on the same machine, I don’t have any crashes (but it is too painfully slow to use…)

To address the loop error questions:

The first thing you can do is go into Edit -> Project Settings -> General and then set “Maximum Loop Iteration Count” to a higher number if you know that’s what you need. Or, you can also try breaking up your loops if possible, avoid using While Loops and look out for For Each Loops in which you are adding things to the array that is being used for the loop.

I would agree that the infinite loop pop-up messages are not useful and I have entered a report that they need to be changed. The reason you are getting so many pop-ups is because it is reporting every infinite loop. So if you have an actor with 3 loops that trigger the infinite loop error and then you have 100 of them in a level, it will give 300 error messages. I’ll see to getting that fixed and made into one message that lists all of the bad loop locations.

Thank you for you feedback, please let me know if there is anything else we can do to improve your experience with UE4.