[4.6.1][Crash] Editor crash on launch

Working on a project that is currently in 4.6.1. It was upgraded from 4.5.1 some time ago, and has been working fine. Prior to closing the project last, the project compiled and saved fine, and ran correctly. However, when I try to open the project now, it crashes back to the desktop after reaching 50% load.

Hi RAVaught,

Is this crash limited to one project or does it occur on a clean project with no additional content? Additionally, can you post your crash logs ( \UnrealProjects\PROJECTNAME\saved\logs\ ) and dxdiag for us to take a look?

I will grab that version of the project and recreate the crash to produce the logs and stuff for you and post them later today.


Hi RAVaught,

Do you receive any errors related to memory when it attempts to load? Specifically:

“Out of video memory trying to allocate rendering resource”

Not at all. The editor tries to load, gets about half way through, hangs for a second and then crashes, no errors given. And I am still trying to get you those logs. The problem is that my bandwidth is pretty bad, and I will need to redownload that version of my repository to recreate the crash. Ben Halliday has access to the SVN repository, and knows which version needs to be pulled down to get the one that is crashing if it would be faster for you guys. The current build is pretty small.

I’m experiencing this issue. My project was upgraded from 4.5.1 to 4.6.1 today, and was working fine.

The editor has crashed after commenting those two lines from (Character.h and cpp, borrowed from ThirdPersonExample project) and trying to compile (on editor):

UPROPERTY(VisibleAnywhere, BlueprintReadOnly, Category=Camera)
TSubobjectPtr<class UCameraComponent> FollowCamera;

The crash remains even after uncommenting the lines back. The editor crashes during load exactly on 50%.

Here is the log file attached


Sorry guys, my problem seems to be unrelated, it was occurring because of a log command being called on GameMode constructor:

GEngine->AddOnScreenDebugMessage(-1, 5.f, FColor::Yellow, TEXT("UETestCharacter constructor started"));

But i’m almost sure that this worked before somehow.


Hi RAVaught,

I wasn’t able to reproduce the crash on my end, the project seems to load just fine. Can you post your dxdiag here? We have some users reporting similar crashes and I would like to see if it may be device specific so we can properly test it.

There ya go, Adam.

link text

Hi RAVaught,

I don’t see anything there that should be causing this crash, have you tried re-verifying your 4.6.1 build? If you go to your launcher library, there is a dropdown menu under each engine build, try verifying your build through that dropdown menu to see if some files are missing or corrupted, these should be replaced during the verification process.

Having very same problem. Will not load past 29% then crash immediately. Cannot open anything and I WAS in the middle of an art test for a job…

Hi kurtophecles,

Are you able to open a clean project with no additional content? Try re-verifying the engine as I posted above, if this does not work try re-installing 4.6.1 onto your computer to see if a fresh install allows you access to your project.

I restarted my machine and it seems to work for now. if it happens again I’ll trey another clean install

Hi RAVaught and kurtophecles,

We have not heard from you in quite some time. I am marking this as accepted for tracking purposes. If you are still experiencing this error, please comment back with the requested information. Thank you.

That’s fine. Sorry I let this one slip through the cracks. It’s been a crazy busy week.