[4.6.1] Can't make new projects

So launching the engine and attempting to start a new project, it runs through everything like normal but gets stuck on 90% and goes into not responding. When I close the engine and launcher, and re-open, the project shows up under My Projects but when I run it it says “MyProject.dll” needs to be compiled, and when I attempt to it just hangs forever. I’ve tried looking everywhere to see if anyone else has ran into this and I’m running into dead ends. If anyone can assist, I’d be grateful!

edit: So it seems I can make blueprint projects fine, but its any time I try to make a code project.

edit 2: Also, it does seem to specifically be 4.6.1, I finally finished my 4.5 download and was immediately able to make a code project, open, build, and run.

Hey BenniKane-

Does this hang up at 90% happen when building/opening the project from Visual Studio or does it happen before Visual Studio even opens? After closing and re-opening the Launcher/engine, does the project show up on your computer in the file location that you created it in? If the folder exists then one thing you could try would be to right click the .uproject file and select the “Generate Visual Studio project files” option to recreate the solution files for the project.

Cheers

Doug Wilson

Hi BenniKane,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Just found this post, as i am experiencing the exact same problem (UE4 4.7.2). The project actually shows up in the Launcher after reopening it and there’s a bunch of files right where they belong on my disk. Assets, source files - everything’s there, except the solution. Regenrating the solution did not come to an end after 2 hours. The log just has one line:

Running C:/Program Files/Unreal Engine/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/***/Documents/Unreal Projects/Proj/Proj.uproject” -game -rocket -progress

Just dowloaded UE4.4. Generation of a code project works like a charm. Once I try to convert it to 4.7, the process won’t finish. Log:

Running C:/Program Files/Unreal Engine/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe ProjDevelopment Win64 -project=“C:/Users/***/Documents/Unreal Projects/Proj/Proj.uproject” -rocket -editorrecompile -progress
Parsing headers for ProjEditor
Reflection code generated for ProjEditor

Hey Cronk-

In the Launcher click the drop down arrow next to the engine version and select Verify. If you are still getting errors when trying to create a project you can try uninstalling / re-installing 4.7.2.

Could have thought of that myself. Sadly, it did not work. Same result as before.

Are you using a source code build of the engine from GitHub or are you using the binary Launcher version? If you are using the Launcher, can you create a project if you bypass the launcher by opening the editor’s .exe file directly?

I’m using the binary Launcher version. Launching the editor’s .exe directly still leads to a never ending “Creating project… 90%”. I will try building the engine from GitHub

Hey Cronk-

We’re currently investigating the issue of users not being able to create code projects (UE-11475). For the time being you may want to use a blueprint project instead or try using another version of the engine if you want/need access to source code.

Cheers

Doug Wilson

I’m also having the same issue.
Using the binary launcher, creating a new project worked fine (UE4 4.7.2). The editor crashed when I tried adding a blank c++ class. Restarted the editor and opened the project. Got an error stating “The following modules are missing or built with a different engine version” UE4Editor-, Would you like to rebuild them now?.

I hit Yes and get the build progress bar. It gets stuck at 0%.
log says
Running G:/Development/Unreal Engine/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe ProjectWolf2 Development Win64 -project=“G:/Development/Unreal Projects/ProjectWolf2/ProjectWolf2.uproject” -rocket -editorrecompile -progress

It stays at this state indefinitely. Once I hit cancel it says to try compiling the source manually.

running win7x64 sp1

OK, I think I found the problem while trying to compile the GitHub version of UE4. The GenerateProjectFiles.bat could not generate any solution for the engine, but it gave me some useful output on the comandline: the problem was my PATH environment variable which, for some reason, contained quotation marks (something like “C:\Program Files (x86)\Java\jre7”). Removing the quotation marks did the trick. I could generate VisualStudio solution files for GitHub UE4, as well as for my own project.
As far as I unterstood the wiki and the batch files output, UE4 is looking for SDKs for different platforms (eg Android) in the PATH environment variable, but does not properly escape the string. But that’s more or less guessing.
Sorry for my bad english. Cheers

Did you try editing your PATH as I pointed out? Can you post the contents of your PATH environment variable?

Awesome. Ya I ended up doing the same thing as you. Went to compile from source and hit a dead end on GenerateProjectFiles.bat. Tracking down the output I found out I just had some trash left over in PATH as well as vcvarsx86_amd64.bat due to trying to fix a bug back when I was trying to build openssl. Thanks for the help. Got everything copacetic on my end.