[4.5 Preview] UMG SetPositionInViewport BUG


I just downloaded the 4.5 preview version just for the functionality to set a widgets screen position dynamically, but it is not working properly!
When I add a User Widget which consists of a button and text block to the viewport and move it with the SetPositionInViewport node, the widget will actually move, however the text block disappears and the button becomes unclickable.


Can you perhaps show your setup?

Of course! It looks like this:

Ah thnx, that looks fine. That same setup works for me. So how about your UMG setup.

Did you move a widget with a button and tried to click it after you moved it?

I tested it on a fresh project, with the same result:
On the right side you can see that the “SetPositionInViewport” node is not connected to the execution chain, so the widget as seen on the top left corner works just fine.

In this picture you can see the setup with the node actually connected, which causes the text on the button to disappear and makes the button itself not reacting to mouse events.

Hi ,

I am attempting to reproduce this issue, but I am having some difficulties. I have set up a create widget in a HUD blueprint with a button with text, then applied the set postition. When set to 0,0, everything vanishes, not just the text. This is expected since I have technically moved everything.

How are your UMG elements set up in the Widget? Can you post images of the designer and graph? Are the elements Anchored in any particular way? Can you recreate this in a simple blank project? Any additional information may help.

This is how the widget looks like.


I am downloading the 4.5 release atm, hopefully taht will fix it.

Just tested it with official 4.5 release, still getting the same error!

Problem solved: I had to use a function called “SetRenderTranslation” rather than “SetPositionInViewport”.