4.5 Android build successful, but push fails on LG G2 device

LG G2 Log

On my LG G2 Verizon, the build will not finish pushing!

The game builds successfully but will never finish pushing. I left it going for several hours at a time, but no luck.

Packaging the build in ETC1 and ALL will also fail in a similar fashion.

Things I have tried:

Devices Used:

  • LG G2 (Adreno 330)

This problem was caused by the following combination:

  1. The size of the obb was too big
  2. Enabling Google Play caused the build to crash.

Hopefully, making the build smaller and setting up the keys for Android will resolve these problems.

Same problem here with LG L90.
What i found is that restarting the phone works for the first time and then pushing hangs, so you can’t launch the map though the editor.


same problem here, push to LG G2 does not work.

Tried with 4.5.1 and Third Person Example project.

Best regards

I have exactly the same problems with my LG G2. I am a bit confused at the moment. With my old Galaxy S3 everything was OK. But with the G2 (more Ram, better GPU) I didn’t expected problems like this.

I have not so many experiences with building apps for Android. How can I disable the Google Play Store? And how can I make the build smaller?

Best regards, Andreas ,