[4.5.0 Preview] Crash when quitting Simulate mode


I’m encountering a crash when quitting the simulate mode with the 4.5.0 preview (built from the github version). At first it was just a long freeze the first times but now it result in a crash systematically. My scenes are empty of any blueprint and I only have some static meshes and lights present.

I have attached to this post the log file.

My specs :

  • Windows 7 x64
  • i7 860 (quadcore) @ 2.8GHz
  • 16GB Ram
  • SSD + HDD
  • nVidia GTX 660

Repro steps :

  • start Simulate mode (ALT+S)
  • Stop simulate mode

After step 2, the editor freeze a little bit (a few seconds) then crash.

Fatal error: [File:C:\GitHub\UnrealEngine\Engine\Source\Developer\MessageLog\Private\Model\MessageLogListingModel.cpp] [Line: 70] 
Critical Error GameplayDebuggingComponent /Game/Maps/UEDPIE_0_test_postprocess.test_postprocess:PersistentLevel.GameplayDebuggingReplicator_Global.GameplayDebuggingComponent_0 Object from PIE level still referenced. Shortest path from root:    (Object is not currently rooted)

KERNELBASE.dll!UnknownFunction (0x000007fefd9dbccd) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!FOutputDeviceWindowsError::Serialize() (0x000007fee3b39e7d) + 0 bytes [c:\github\unrealengine\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
UE4Editor-Core.dll!FMsg::Logf__VA() (0x000007fee39d59af) + 0 bytes [c:\github\unrealengine\engine\source\runtime\core\private\misc\outputdevice.cpp:522]
UE4Editor-MessageLog.dll!FMessageLogListingModel::AddMessageInternal() (0x000007fed775c445) + 150 bytes [c:\github\unrealengine\engine\source\developer\messagelog\private\model\messageloglistingmodel.cpp:70]
UE4Editor-MessageLog.dll!FMessageLogListingModel::AddMessages() (0x000007fed775c53f) + 79 bytes [c:\github\unrealengine\engine\source\developer\messagelog\private\model\messageloglistingmodel.cpp:89]
UE4Editor-Core.dll!FMessageLog::~FMessageLog() (0x000007fee3940eb5) + 58 bytes [c:\github\unrealengine\engine\source\runtime\core\private\logging\messagelog.cpp:91]
UE4Editor-UnrealEd.dll!UEditorEngine::EndPlayMap() (0x000007fedf1ca956) + 414 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\playlevel.cpp:217]
UE4Editor-UnrealEd.dll!UEditorEngine::Tick() (0x000007fedefa78f4) + 0 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\editor.cpp:1470]
UE4Editor-UnrealEd.dll!UUnrealEdEngine::Tick() (0x000007fedf3ff816) + 0 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\unrealedengine.cpp:278]
UE4Editor-Cmd.exe!FEngineLoop::Tick() (0x000000013f7cb224) + 0 bytes [c:\github\unrealengine\engine\source\runtime\launch\private\launchengineloop.cpp:2129]
UE4Editor-Cmd.exe!GuardedMain() (0x000000013f7c0c3e) + 0 bytes [c:\github\unrealengine\engine\source\runtime\launch\private\launch.cpp:133]
UE4Editor-Cmd.exe!GuardedMainWrapper() (0x000000013f7c0caa) + 5 bytes [c:\github\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor-Cmd.exe!WinMain() (0x000000013f7cc859) + 17 bytes [c:\github\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:201]
UE4Editor-Cmd.exe!__tmainCRTStartup() (0x000000013f7cd33d) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
kernel32.dll!UnknownFunction (0x000000007792652d) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x0000000077b5c521) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x0000000077b5c521) + 0 bytes [UnknownFile:0]

link text

Hey . Does this also happen in a blank project?

I can’t reproduce it on a new C++ project (TemplateThird). However I could share my current project (but not publicly, it’s about 280mb compressed). If that’s okay I could send a download link via an e-mail.

You can send the link to me on the forums through private messages. My username there is Jonathan.Dorman just like it is here.

Done. You should have received a PM. :slight_smile:

Hey ,

Good news and bad news. The good news is that we’ve found the problem and fixed it internally. The not-so-good news is that the fix might not be implemented in time for 4.5. You’ll probably need to find a workaround until then.



Great ! :slight_smile:

Is this a fix I could integrate in my own build since I’m using the github version ? Or maybe do you have a specific commit on github that I could integrate ?

We implemented a fix in the most recent Main build, but I can’t actually build the project in that version of the engine (which means pulling that commit might not do you much good!). Once the Main build has been made more stable (closer to 4.6’s release), I expect that it’ll solve your problem.

That said, you’re welcome to try Main and see if you have better luck there than I had.

Well, I’m willing to give a try. I looked into the commits from the last 24 hours of the main branch but I wasn’t able to identify the one related to my issue, could you indicate me which one it is ?

I’m not extremely familiar with our GitHub commits (I don’t pull individual commits), but this may be the one:

I tried implementing this commit, but it didn’t help. Is this error message a symptom for something specific?
This happened to me after implementing a new component. Are there some special GC related things I am missing?

This commit didn’t help me either, I’m still experiencing the crash. I didn’t had more time to investigate so for the moment I’m living with it until 4.6. :\

Okay, I think I finally found the right one: https://github.com/EpicGames/UnrealEngine/commit/8a7cb17cb3e0f92f3b859b0a0e019094d2b82da3

The date of the commit is before my post, is that normal ? Also in my 4.5.0 source code my function RequestEndPlayMap() only contains :

	if( PlayWorld )
		bRequestEndPlayMapQueued = true;

Since the commit you linked mention only one line change inside a bigger code snippet, its seems the code moved a bit. I also don’t see any mentions of the variable “bLastViewAndLocationValid” in the rest of the original source code. It’s hard to follow what happened. :\

I’m not certain whether or not the commit I linked was included in 4.5.0, but it seems to address a crash caused upon exiting Simulate mode. That’s why I assumed it was the correct fix.

The crash was fixed in the build I tested on Oct 8, but I don’t know the precise changelist.