[4.4] BlueprintPure nodes created in C++ cannot be called in AnimGraph

Dear Friends at Epic,

So I made a C++ BP node as follows

/** Set this AI's target! Should only be called on the server! */
	UFUNCTION(BlueprintPure, Category="Evolver Targeting")
	bool AI_TargetIsStructure();

When I go to anim graph and use try get pawn owner, the above node does not show up!

#What Works

If I change it from Pure to Callable it shows up!

/** Set this AI's target! Should only be called on the server! */
	UFUNCTION(BlueprintCallable, Category="Evolver Targeting")
	bool AI_TargetIsStructure();


This is pic of what I am trying to do where the BP Pure does not show up

I am using Try Get Pawn owner int he Anim Graph off of an Anim Notify event.


Any idea why BP Pure is not working in the AnimGraph off of try get pawn owner?!

Same here. Using UFUNCTION(BlueprintPure) doesn’t seem to make the function callable from a Blueprint graph. I’ve never tried this before so I’m not sure if it’s a bug or I’m missing something.
From the BlueprintPure reference: “The function does not affect the owning object in any way and can be executed in a Blueprint or Level Blueprint graph.”

I haven’t try 4.4 yet not sure this help, with all my BlueprintPure in Animation Blueprint i always put function return as void.

UFUNCTION(BlueprintCallable, BlueprintPure, Category="Evolver Targeting")
void AI_TargetIsStructure(bool& Out);

Nice to hear from you Pablo!

Thanks for the input Duncan! Your answer will surely help Epic to address this,

Epic I would like to know if it is expected behavior that only void return value blueprint pure show up in the Anim BP?

Hey -

I just wanted to check if this was still occurring for you? If so could you check to see if it occurs in 4.6 as well?


#For You

Just for you , I made a C++ BP pure node in my Anim Instance class, and… now it works as of 4.6!

Thanks for checking in !