4.4.3 Animation loop Bug

Just updated From 4.4.2 to 4.4.3 on Mac OSX and all my animations are blending to fast from the last frame to the first frame when looping resulting in all my characters limping when they walk
Tried “add loop interpretation” which adds the first fame to the end making the animation from 30 to 31 frames long and the animation and still limping .
now the limp is between the frame 30 and 31.
it seams there is a frame missing somehow.
??? anyone else have this problem
is there a way to un-instal 4.4.3 and revert back to 4.4.2?

bump! bump!

I think I really fixed this now, but we need to resave contents. We’re working on fixing the contents for the next release.



That’s good to hear but will the ADD LOOP INTERPRETATION bug be fixed or do I have to add frames to all my animations and reimport them? I’ve not been working on my main project because of this issue.


I’m following up to see if you are continuing to experience an issue with the animation looping incorrectly. If so, have you tried updating to the 4.6 version of the engine? This latest release contains a lot of fixes to reported bugs as well as a lot of great new features.

If you are not able to update or are still encountering the same problem after updating, please let us know by responding to this post and we will investigate the matter further.


Hi , i have tried 4.6 with some of my smaller mobile projects and 4.6 has more bugs than fixes, new features aren’t that interesting to me if the engine keeps stalling.
my main project has been on hold because of this since 4.4.3 and would involve a lot of time to upgrade it to 4.6 time i feel would be better spent looking into alternative engine options. I’ve been a constant subscriber since 4.0, long enough for me to see a pattern arise which does not suit me and my business.
cheers anyway

This one should be fixed for 4.6. Sadly you’ll have to “Add Loop Interpolation” again to apply correct interpolation. To do so, you might like to revert prior to adding loop interpolation, and apply it again.

Apologize for this trouble.