[4.3] UE4Editor-ShaderFormatOpenGL.dll : fatal error LNK1120: 1 unresolved externals


I get the following problem when trying to compile 4.3 preview from source:

 Creating library E:\Users\username\Documents\GitHub\UnrealEngine\Engine\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-ShaderFormatOpenGL.lib and object E:\Users\username\Documents\GitHub\UnrealEngine\Engine\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-ShaderFormatOpenGL.exp
1>Module.ShaderFormatOpenGL.cpp.obj : error LNK2019: unresolved external symbol "int __cdecl HlslCrossCompile(char const *,char const *,char const *,enum EHlslShaderFrequency,class FCodeBackend *,struct ILanguageSpec *,unsigned int,enum EHlslCompileTarget,char * *,char * *)" (?HlslCrossCompile@@YAHPEBD00W4EHlslShaderFrequency@@PEAVFCodeBackend@@PEAUILanguageSpec@@IW4EHlslCompileTarget@@PEAPEAD5@Z) referenced in function "void __cdecl CompileShader_Windows_OGL(struct FShaderCompilerInput const &,struct FShaderCompilerOutput &,class FString const &,enum GLSLVersion)" (?CompileShader_Windows_OGL@@YAXAEBUFShaderCompilerInput@@AEAUFShaderCompilerOutput@@AEBVFString@@W4GLSLVersion@@@Z)
1>E:\Users\username\Documents\GitHub\UnrealEngine\Engine\Binaries\Win64\UE4Editor-ShaderFormatOpenGL.dll : fatal error LNK1120: 1 unresolved externals

I’m using commit eef380b6c6edaaa6633863cf522865e571873f4a and have downloaded and extracted the two new required zip files as described.

Hi ,

Just to clarify, did you sync the entire source code, or only that one commit? If you merged only that one commit into your source code for 4.2 and tried to build the Engine with the 4.3 dependencies, then the build won’t complete successfully.

I cleaned my old folder and synced the entire source code. Then I extracted the dependencies from the zip files and got the compiling error above. I will try to pull all coming changes but haven’t had any success yet which forcing me to using the unreal binaries directly.

Hi ,

I was able to successfully build 4.3 this morning using a brand new repository forked from the Unreal Engine repository. Are you still having trouble building 4.3?

Thanks for letting me know. I tried from scratch again and now it compiles. Thank you!