[4.3] Issue with physics object as part of a scene (Blueprint)

I’m having an issue with physics objects that are children of scene components since the update to 4.3, basically if you set simulate physics on the physics object in the components tab of the blueprint and zero the physics object at runtime and move the entire actor to a position the physics object ends up zeroed in the world (not the scene).

BUT if you disable simulate physics in the components tab, disable and then re-enable simulate physics and collision at Begin Play it functions normally. I made a simple test on a new project (just a cube as a child of a scene component in a new blueprint) and I was still getting the same results (see below).

Doesn’t work with simulate physics in components tab:

Works if you disable simulate physics in components tab and enable at Begin Play:

If you plug Begin Play up to the second Set Simulate Physics node it has the same issue as above.

Any idea what’s going on here that may have changed since 4.2?

Hi Leighroy,

Does this only occur in one project or can you reproduce it in a blank project with no additional content? I have attempted to reproduce it on my end but thus far it seems to be acting as intended.

Hi ,

This was done on a blank project as well as happening on my main project, I made a third this morning to make sure I’m not crazy and I’m still getting the same result.

I’ve attached a picture of how my actor is set up in the components tab (this setup causes the box to zero to the world, it zeroes to scene if you disable simulate physics in the components tab and disable and re-enable physics and collision at runtime).

Thanks for looking into it!

Hi Leighroy,

At least so far we have been unable to replicate this. What is the exact outcome you are looking for when you use this blueprints? Perhaps a clearer understanding will help us to locate this potential bug.

Hi ,

I’ve attached a copy of the test project and blueprints (hopefully the project still opens, I had to strip it out quite a bit to get them down to size).

Basically the two cube blueprints should have identical behaviour, shortly after start they’re both simulating physics with collisions enabled, but when they execute the delay only the one where I’ve toggled physics and collision at runtime performs how I’d expect (and how it was working in 4.2 and earlier). I’d expect that when I disable physics and zero the cube in the blueprint scene then move the entire scene in the world that the cube would go with it, rather than zero in the world.


Hi Leighroy,

I was able to reproduce this and have entered a bug report in to be assessed. Thank you and have a great day!

i have exactly the same problem which drove me … hopefully this will get fixed soon!!

is there any fix out yet?

i need this working properly for my game

Hi ,

This is still currently under assessment by our development staff as TTP#342106. I unfortunately do not have a timeframe on a fix for this as of yet.