Download

4.3 Failed to produce item UE4Editor-SpeedTreeImporter.dll

Hello. I switch to the bracnh 4.3, and after this i get error while build the engine.



 [535/620] link.exe UE4Editor-PhysXFormats.dll
1>     Creating library W:\UE\UnrealEngine\Engine\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-PhysXFormats.lib and object W:\UE\UnrealEngine\Engine\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-PhysXFormats.exp
1>  [536/620] link.exe UE4Editor-PerforceSourceControl.dll
1>  [537/620] link.exe UE4Editor-SpeedTreeImporter.dll
1>  [538/620] link.exe UE4Editor-PhAT.dll
1>LINK : fatal error LNK1181: cannot open input file 'SpeedTreeCore_Windows_v7.0_VC12_MTDLL64_Static.lib'
1>  [539/620] link.exe UE4Editor-SessionFrontend.dll


What is the problem? $(

Same issue, haven’t found a fix yet.

If you are not going to use Speedtree you can just remove the “Speedtree” code from the Source/Plugins folder and rebuild.

So it looks like maybe a more recent commit to 4.3 branch is the culprit. I just pulled down the 4.3 ZIPs and built just fine.

Same problem. I’m just going to copy my post from another thread:

Anyone else having problems building 4.3 (switching over from 4.2)? Seems like the Speedtree implementation is the culprit:

I applied the new .zip dependency content. I recreated the project files using GenerateProjectFiles.bat. Settings set to Development Editor and Win 64.
I have used Rebuild All. Three times (with normal builds inbetween).
SpeedTreeCore_Windows_v7.0_VC12_MTDLL64_Static.lib is present.

edit: Right-clicking the speedtree libs and I see they were blocked because they ‘came from a different computer’. I unblocked them. Tried re-building but still no success (‘can’t open inpput file’). Looking up error: http://support.microsoft.com/kb/815645

Okay it’s working now.

Re-download the dependency .zip packages and fetch the latest commits. Seems like Epic handled it on their end.

The .zip packages & source from yesterday (June 3rd) was the one giving me problems.